FireTV box stuck in setup loop since update

DominoUk

Member
I decided to do a factory reset on my 1st generation Fire TV box [Not stick or cube], During the setup it did an update, Since the update the box will no longer load, It goes through the setup process until "Loading" appears in the bottom right, But then goes back to the start of the setup process again, Over and over, I have contacted Amazon but they are no use whatsoever.

Has anyone else had this problem and was it ever fixed.

Press play/pause to start

Select my country

Checking for updates

Connecting to Amazon

[I have tried entering the code to register, And also tried entering in manually]

Successfully registered

Your Amazon FireTV is registered too [My Name] > Continue

No Parental controls > selected

Loading appears bottom right [Sometimes Optimizing appears first]

Then the "Press start/pause to start" appears again, And the whole above starts again, over and over !!



Box is plugged directly into wall socket [Not into an extension lead]

Box is plugged directly into wired Ethernet [Have also unplugged it and tried WiFi]

No external storage installed

Tried three TV's

Tried all HDMI in said TV's

Tried leaving it on the Play/Pause screen for a long time, Never changes

Tried many more factory resets, Still the same.



Is there anything i can do or has Amazon update destroyed my box ?



Thanks
 
Last edited:

The latest video from AVForums

AVForums Movies Podcast: Which is the best decade for horror movies?
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom