• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Finder continuously crashing/relaunching

Matt_C

Distinguished Member
I cloned my HDD yesterday eve to a new SSD drive (using SuperDuper), then swapped the physical drives in the machine and rebooted. After an initial problem of a long boot time, that was resolved by going to System Preferences > Startup Disk and selecting my SSD drive (even though it was the only one listed, selecting it and hitting reboot seemed to solve it, and it now boots much faster), it all seems to be working, apart from one thing - Finder keeps crashing/relaunching.

With a Finder window open, it constantly (times vary, but between 15 and 40 seconds usually) "blinks", where it disappears from the screen, then reappears. The icons on the desktop do this too. If I'm trying to copy a file from, say, my Mac to a network disk (and I'd assume the same goes for a USB disk, but I haven't tried that yet, since my USB flash drive currently has a Mountain Lion boot/install image on it), after 15-40 seconds Finder crashes and relaunches, cancelling the transfer. I'm left with a partial file (that looks faint in Finder, rather than bold as it normally would) that I have to delete and try again - and the cycle continues.

I'm not getting any error messages like you normally get when an application fails/crashes. It literally just blinks and (usually) reopens the window where it was.

I've tried so far;

  • Booting into Safe Mode (boot + shift)
  • Logging out and back in + shift
  • Deleting the com.apple.finder.plist file from the Library folder and letting it rebuild (both on reboot and via relaunching Finder)
  • Verifying disk and permissions, and repair disk in Disk Utility
None of the above has solved it, however, the second one (logging back in holding shift) has bypassed it. When I did that, I was successfully able to copy two files, both around 5gb each, to my Network drives, which took around ten mins each, without any Finder crashes.

So I'm wondering if the problem is within my user account. Something hasn't copied over correctly, something is corrupted, etc. Next things I can think off, before reinstalling ML and recovering backup from Time Machine, is to turn off all startup/login applications (of which there are a few) and then enable one by one to see if one is a trigger, and also wondering if a PRAM reset might work.

I'm not sure, but I assume I have the ML recovery thing on this drive (how do I find out if I have?) and if so, have I read correctly that I can use that to rebuild the ML OS without having to do a full reinstall, and it keeps my settings and data preserved? If so, if the problem exists in the OS files, maybe that will solve it, but if the problem exists in the user settings, files and applications, I'm not sure it will?

Any ideas?
 

Matt_C

Distinguished Member
Update;

Decided to do a PRAM and SMC reset on it, which didn't seem to make any difference far as I can tell. So I went into System Preferences > Users > Login Items and just removed everything in there (which as said before, was quite a few; two applescripts (set as applications to mount two network volumes), a few Apps; Dropbox, Google Drive, NotesTab, Volume for iTunes, Switché, VMWare Helper, BetterTouchTool, and a couple others, and then set about re-adding them one by one, logging out and back in after each one added. Everything was going fine until I added Google Drive back in - soon as I logged in after re-adding that, I got the Finder window, and desktop icons, "blinking" again, and Finder crashing off the screen. Removed it from Login Items again, logged out and back in, and far as I can tell Finder is ok. I haven't bothered to re-add a few of the Login Items, VMWare Helper, Switché, and the others I rarely if ever use these days, so as to keep it as a minimum.

Will try a cold boot and see if it continues to work as it should, or reverts to crashing/relaunching - but hopefully, Google Drive is the problem. I know when I booted up for the first time after fitting the SSD, Google Drive wanted me to log back in, and then had trouble saying it can't find the GD folder, then when I pointed it at it, it told me it can't use it because it was linked to a previous something or other, and I had to log out of GD, log back in, and allow it to delete all the files in it and redownload them. So maybe I'll just try uninstalling it completely, install it from fresh and see if it works.
 

The latest video from AVForums

Fidelity in Motion's David Mackenzie talks about his work on disc encoding & the future of Blu-ray
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom