Finally received my PL10 from Empire, however...

Discussion in 'General TV Discussions Forum' started by Dream Weaver, Feb 5, 2002.

  1. Dream Weaver

    Dream Weaver
    Active Member

    Joined:
    Jan 13, 2002
    Messages:
    77
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Location:
    Lancashire, UK
    Ratings:
    +7
    Finally got my new TV this afternoon, after a 2 month wait from Empire.

    It is my first widescreen, so I dont know what to expect. However, one thing I have noticed is that the screen is jagged on the left and right when viewing in certain aspects (i.e. 4:3), and also when playing on the PS2.

    Is this common, and any way of fixing it - I really dont fancy dealing with Empire again if anything goes wrong with the TV as I dont trust them enough to sort it.

    Please help a newbie :)

    DW
     
  2. Dream Weaver

    Dream Weaver
    Active Member

    Joined:
    Jan 13, 2002
    Messages:
    77
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    11
    Location:
    Lancashire, UK
    Ratings:
    +7
    Also just realised that it has the "sound hum" that people have mentioned on this forum - any fix for this?

    DW
     
  3. PND

    PND
    Standard Member

    Joined:
    Nov 1, 2001
    Messages:
    25
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Location:
    Leeds
    Ratings:
    +0

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice