File sharing over home network only works one way

Otaku Punk

Active Member
I'm really confused as to whats going on so i thought i'd ask for a little help with my situation.

A couple of months ago i brought my PC home from uni as i usually do in holidays and connected to my home network via wireless. I always use a wireless connection at home and an ethernet connection at uni. Setting up the shared internet and networking all seemed to go fine, with both working perfectly as far as i could see. I was happily sharing the family printer and accessing the net.

The problems arised when the other two computers in my house tried to access my PC (one connected to the network wirelessly and the other via ethernet). My Shared folders don't appear in "network places" but my computer does appear in "view workgroup computers". Both PCs get an error message when they click on my computer in "view workgroup computers" that reads as follows:

"\\(my computer name) is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions

Access is denied"

I've pinged my computer from one of the other PCs using both the local IP and my computers name, and found no packets dropped. I've tried disabling my firewall and unsharing/re-sharing the folders i want on the network but to no avail. As a last ditch attempt i even tried re-running the networking wizard with no success. What really puzzles me is that file sharing has worked perfectly fine in the past, and that i can access the other computers with no problems.

Any help with this would be greatly appreciated, i'm pulling my hair out!
 

Andy98765

Distinguished Member
Are all computers in the same workgroup, XP default is MSHOME. I noticed on Vista that this has changed back to Workgroup = WORKGROUP.
If you are running Norton Internet security it also has to be configured to allow inter computer acceptance. Look in Personal Firewall, Configure Personal Firewall, Networking, click on the wizard and let Norton do the rest.
 

bsuttie

Active Member
If you're running XP Pro it could be the same problem I had which was lack of passwords on the other users computers :

Windows XP professional will not allow network users computer access without a password. Trying to do so will normally return and error code. To allow network access using a blank password:
[Start] [Run] and type gpedit.msc and click [OK]
Navigate to Computer Configuration /
Windows Settings / Security Settings / Local Policies / Security Options
Double click on Accounts: Limit local account use of blank
passwords to console login only.
Select the radio button next to Disabled and click [OK]


HTH

Brian
 

Otaku Punk

Active Member
Are all computers in the same workgroup, XP default is MSHOME. I noticed on Vista that this has changed back to Workgroup = WORKGROUP.
If you are running Norton Internet security it also has to be configured to allow inter computer acceptance. Look in Personal Firewall, Configure Personal Firewall, Networking, click on the wizard and let Norton do the rest.

All three computers are on the same workgroup, and the only software firewall all the computers are running is windows firewall. All three are using McAfee Antivirus, which doesn't have a firewall option (at least not the version thats installed).

Bsuttie, just tried that but doesnt seemed to have worked. I'll test it again after a restart. I'm using Xp Pro myself.
 

The latest video from AVForums

LG G1 OLED Evo TV and SVS SB-1000 Pro subwoofer reviews, Samsung OLED rumours and more...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom