Ffdshow & Zoomplayer working/not working together

Cocksure

Well-known Member
Help!
I am hoping someone can explain to me why ffdshow sometimes works with zoomplayer and sometimes not? :lease:Eg with some Avi files I get zoomplayer & ffdshow video & audio decoder or just zoomplayer and ffdshow video decoder, with Matroska files I get zoomplayer & ffdshow video only (with Dscale5 for audio) and with vob files I get no ffdshow what so ever (only get Dscale5 for both audio and video).

I have selected both ffdshow filters in the playback dvd options menu of zoomplayer (in smart mode), but it doesn’t seem to matter what option I pick as it still does its own thing. :confused:
 

MikeK

Novice Member
It may depend on what's in those AVI and MKV containers (ie the video could be WMV9, Xvid, H264, MPEG2, VC1.....etc etc, and the audio could be PCM, AC3, DTS, FLAC....etc)

FFDSHOW has to be enabled to decode each format, regardless of whether you select ffdshow in ZoomPlayer.
You do this from the Start - Programs - FFDSHOW - Video/Audio configuration - codecs.
You then select whether to enable ffdshow for decoding each format!

For instance, under video codecs, if you want ffdshow to decode H264/AVC, then in the list you must change it from "disabled" to "libavcodec".
It's the same for any other codec you want ffdshow to deal with, including audio.


What's probably happening is that although you are telling ZP to use ffdshow to decode say H264, when ZP calls ffdshow to actually do it, ffdshow responds that it can't (as the relevant format/codec is disabled) - ZP will then select the next highest merit filter which can do the decoding, from the DirectShow engine.


HTH



BTW, "Gspot" and "Graphedit" are two very useful tools to tell you which codecs are being used for any particular file.
In Graphedit, if you simply select Render file, and then pick the file you want from the selection box which opens, Graphedit will open the file
and show you the filter graph (ie the combination of filters being used) it's currently using to playback that file!
Gspot does much the same!
 

Zarch

Well-known Member
Lizard,

Have you looked at the codec help thread?
http://www.avforums.com/forums/showthread.php?t=652538

Personally, i'd disregard zoomplayer for now and get all your files working at the base system level, ie through graphedit using the codecs only. (graphedit will show you the codecs currently in use for each filetype).

Remember, each video file type needs different codecs in place to play them.

Once you've everything working in graphedit, then go back to Zoomplayer (and if you've got things working using graphedit, you shouldn't need to play with any settings in zoomplayer)

Hope this helps.
 

Cocksure

Well-known Member
Thanks for the replies.:thumbsup:

FFDSHOW has to be enabled to decode each format, regardless of whether you select ffdshow in ZoomPlayer.

For instance, under video codecs, if you want ffdshow to decode H264/AVC, then in the list you must change it from "disabled" to "libavcodec".
It's the same for any other codec you want ffdshow to deal with, including audio.
Its not this alas :( as I have checked to make sure the codecs were enabled and I am still getting no joy (used Gspot first to identify codes)


Have had a quick look at it thanks :smashin:(will need to study it better tomorrow)

Once you've everything working in graphedit, then go back to Zoomplayer (and if you've got things working using graphedit, you shouldn't need to play with any settings in zoomplayer)
This is were I am starting to get really confused :confused:, I am for the time being just concentrating on the one file type that is giving me the most grief (mpeg2 :mad:) and I have tried the file in both Gspot and graphedit (still trying to understand the basics of both), were they both tell me I have all the codecs installed that are needed and play them both fine with ffdshow, however as soon as I open zoomplayer I’m back to dscale5 and not ffdshow. :suicide:
 

Cocksure

Well-known Member
Well I'm delighted to say that i have fixed the problem and got Zoom Player and ffdshow working properly together again and how i want. :thumbsup:

It turned out that the problem was in how the filters were set up in the smart play option, of the option and set up of zoom player, all i had to do was choose the file type that was giving me the issue and reconfiger the filter used to decoded it.

Couldn't have done it with out Gspot & Graphedt, so a big thanks MikeK & Mickwall. :thumbsup:

PS i can see me using thoughs two applications quite a lot in the future, their very handy :)

PPS, one quick non connected question, can anyone recommend a good site for joining usenet with for media file download? their are loads out their and i've no idea which are good or not, so far i'm leaning to usenext, but if anyone has any views i would be very grateful.
 

Zarch

Well-known Member
Couldn't have done it with out Gspot & Graphedt, so a big thanks MikeK & Mickwall. :thumbsup:

PS i can see me using thoughs two applications quite a lot in the future, their very handy :)
Another satisfied customer! LOL. :rotfl:
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom