FFDShow H264 decoder issues

djcla

Distinguished Member
I have tried numerous versions and the h264 decoder just gives me audio and a green screen broken up with fragments of picture. This happens using DXVA or not. Splitter is the one from MPC-HC and non H264 HD mkv's works just fine. Is no one else suffering from this??
 

eddiem74

Active Member
If using ffdshow DXVA, have you disabled H264 in the regular ffdshow codec section?

If yes, what is listed 'Directshow Filter Control' section, around 'Multiple ffdshow instances'?
 

djcla

Distinguished Member
i leave it enabled as m using win7dSfilter manager to select the DXVA version of the decoder in the registry .. Have tried disabling it before and it made no odds
 

eddiem74

Active Member
If using ffdshow DXVA, have you disabled H264 in the regular ffdshow codec section?

If yes, what is listed 'Directshow Filter Control' section, around 'Multiple ffdshow instances'?
I am sure you seen in Davey's ffdshow thread Wolvers was having issues, and disabling resolved for him, although if merits are correct, it could be to do with the Directshow Filter control section. You never stated what was listed there.

i leave it enabled as m using win7dSfilter manager to select the DXVA version of the decoder in the registry .. Have tried disabling it before and it made no odds
Well from my limited non-ffdshow expert experience, after any win7dsfilter changes you need to reboot. I would also disable the codec in ffdshow standard. You also need to consider the 'Directshow Filter Control' section, around 'Multiple ffdshow instances'.

I also had similar issues and doing some combination of the above resolved it.
 

djcla

Distinguished Member
It is using the correct decoder but i get a green screen and i dont think its a merrit issue etc.. MS decoder works fine MPC-HC works fine.. FFDShow works fine for VC1 stuff just not H264 it splits and plays i just get a green screen..
 

djcla

Distinguished Member
If yes, what is listed 'Directshow Filter Control' section, around 'Multiple ffdshow instances'?
i did not quite understand this question , should i just push the H264 decoder up the list i guess its worth a shot??
 

eddiem74

Active Member
I was referring to the Directshow Control as listed in the 1st screenshot in this post. I am not saying the 'Multiple ffdshow instances' needs to be the same as what is listed in the screenshot, but you can try using some of the alternative options and see if it makes a difference.

Unfortuately not much more I can help with, I would suggest you post up some mediainfo details of the file, a graphedit pic, and a pic of what the ffdshow icons say when you hover over them when playing the file. Hopefully then some others will have input.
 

djcla

Distinguished Member
I was referring to the Directshow Control as listed in the 1st screenshot in this post. I am not saying the 'Multiple ffdshow instances' needs to be the same as what is listed in the screenshot, but you can try using some of the alternative options and see if it makes a difference.

Unfortuately not much more I can help with, I would suggest you post up some mediainfo details of the file, a graphedit pic, and a pic of what the ffdshow icons say when you hover over them when playing the file. Hopefully then some others will have input.
ok ta yeah i have amened that setting but to no avail
 

djcla

Distinguished Member
fresh rebuild of win 7, files all work fine in MPC-HC and sing MS codec's ,. But H264 content will not play with FFDshow DXVA or non DXVA yet again green blocking on screen VC1 is fine.
 

jameson_uk

Novice Member
I have found the FFDShow HD codecs to be very flaky so have avoided them (they are very early beta versions so it is to be expected)

The MPC-HC H264 codec seems to work a lot better and has less issues with connections to MPC-HC splitters
 

djcla

Distinguished Member
shame i cant integrate the MPC-HC decoders and Sub readers into MCE some how. If if there is a way im not sure how to do it
 

jameson_uk

Novice Member
shame i cant integrate the MPC-HC decoders and Sub readers into MCE some how. If if there is a way im not sure how to do it
Use MediaPortal ;)

Can you not set the MPC codecs in the same way you set the FFDShow ones ? (sorry have not used MCE/7MC etc)

As for subs, I am fairly sure that the MPC sub engine only works inside of MPC and MP (they have built it in) so I don't think there is a lot you can do there :(
 

djcla

Distinguished Member
Use MediaPortal ;)

Can you not set the MPC codecs in the same way you set the FFDShow ones ? (sorry have not used MCE/7MC etc)

As for subs, I am fairly sure that the MPC sub engine only works inside of MPC and MP (they have built it in) so I don't think there is a lot you can do there :(
its the SUb's that are the issue im happy with the Microsoft codecs they are great (yes i know ) but dont work to well DXVA wise when subs are enabled using Vsub and HD Audio etc. Ah well stick to MPC-HC for now
 

djcla

Distinguished Member
no i have never got it to work, when you hover over the DXVA icon (its the same non DXVA) the media shows as H264
 

wolvers

Novice Member
And you've tried various different versions of ffdshow?

It's very strange, could there be something on your system that is causing a conflict?
 

djcla

Distinguished Member
And you've tried various different versions of ffdshow?

It's very strange, could there be something on your system that is causing a conflict?
Have tried a few different version but all quite recent. I will try a few files on my bedroom htpc and see what happens .
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom