Feedback through speakers

Roadkilled

Standard Member
Hi everyone,

First off I hope this is the right section for this post.

I bought a new Arcam amp a few days ago to replace my Nad amp that died on me. This amp is used in my front room to power my Bose speakers and also controls the cordless headphones (used to listen to things after the mrs has gone to bed). The two main inputs for the amp are the TV and my laptop.

The Nad amp worked perfectly with no problems at all but the Arcam is getting feedback through the speakers. It's taken ages to figure out what's going on but tonight I was having yet another look see and I for some reaso thought I'd see what happens if I unplug the power to the laptop and low a behold the feedback stopped.

Any of you guys heard of the power source of laptops coursing feedback before or how it's possible to workaround.

Amp and laptop are in a stand alone unit but the laptop is a good 2 feet fom the amp.

Would really appreciate any help any of you can give.

Cheers, Jon
 

larkone

Distinguished Member
Sounds like you may have a noisy Switched Mode Power supply on your laptop. Things to try are another power socket on a different ring, or another power supply or run it off the battery when listening to music - this is always the preferable route when using a laptop for music into a sound system.

More info here if you are interested
Switched-mode power supply - Wikipedia, the free encyclopedia
 

Roadkilled

Standard Member
Hi Larkone, thanks for your response. Unfortunately the battery on the laptop holds very little charge these days as its been plugged in inside the tv units for so long. So do you think if I get another power cable for the laptop this will cure it? I can't figure out why it's doing it now with the new amp. One thing to add is that the feedback noise doesn't go up or down when the volume is up/down.

Thanks in advance, Jon
 

larkone

Distinguished Member
It is not the power cable but the power supply brick assuming it is an external power supply. If it is an internal power supply then you are stuck. Replacement batteries are not that expensive as long as you avoid the original manufacturers route. Look for the serial/model number on the battery and stick it into ebay and it may be possible to find a higher capacity battery for a longer life. That is the number on the battery in mAH - the higher the number the greater the capacity
 

Roadkilled

Standard Member
Thanks mate, still don't understand why I'm getting feedback now and the other amp was perfect. Any ideas?
 

Roadkilled

Standard Member
Hi larkone, just to let you know I've ran a new socket from a different ring and it's worked a treat. Thank you very much for taking your time to resolve my problem.

Cheers, Jon
 

The latest video from AVForums

Podcast: Trinnov Room Optimiser: A full explanation of Trinnov and its room optimiser technology
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom