1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Faulty Speaker Output??

Discussion in 'AV Receivers & Amplifiers' started by Windy, Jul 25, 2002.

  1. Windy

    Windy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have recently set up my GHC50 and found that I cannot seem to get audio from my front right speaker. When listening to it there is some static but no sounds.. All other speaker outputs are ok. I have tried the speaker in another output i.e. front left and it works ok. Does this appear to be a problem with the speaker output and if so is it quite easy to repair or will I need to send it back?

    Any help or advice would be greatly appreciated
     
  2. Jase

    Jase
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    9,462
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    South Coast
    Ratings:
    +888
    Hi

    If the speaker is ok when changed to a different output then I´m afraid it would seem the output is at fault, not the speaker.

    You would need to take it back to a service centre or whereever you bought it. Presumably its covered under warranty.
     
  3. Windy

    Windy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks!.. luckily it is still under warrantly so i'll take it back asap
     

Share This Page

Loading...