Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Faulty Sony PFM42B1E Can anyone fix it?

Discussion in 'Sony TVs Forum' started by CustardPTT, Jun 10, 2005.

  1. CustardPTT

    CustardPTT
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi All,

    I have a Sony PFM42B1E, which has stopped working. According to Sony as this is a 'Professional' unit it must be repaired by sony at a minimum cost of £700 and with a lead time of 4 weeks.

    Is there anyone in the London Area willing to have a go at repairing this unit? Or can point me to a possible repair?

    Fault:
    Standby works as expected, when switched on fans start as normal but no screen, I can hear a a faint ticking noise (about every 2 secs) which sounds a like a relay or power supply. The Power light flashes in time to this. I tried taking the back off and sticking a meter on to one of the power supplys marked 150V. This is powering up for a fraction of a second in time with each tick.

    Thanks for taking the time to read this post
     
  2. hornydragon

    hornydragon
    Well-known Member

    Joined:
    Dec 19, 2001
    Messages:
    28,346
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Somewhere near the M4 most of the time......
    Ratings:
    +1,218
    well its a rebadged plasma from someone else, try OWL video for a quote, also there will be plenty of "Pro dealers" in london that will quote for a repair
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice