Faulty Samsung SV657B VCR

Damian1978

Well-known Member
Hi chaps,

I'm really miffed with the above 10 month old video.

It hasn't had that much use and after getting a Pace Twin its used once a week for about 90 mins.

I installed a Joytech scart switcher on Monday so unplugged the VCR, TV etc from the mains. When I plugged it all back in a tried a video the sound crackled all the time and nearly the bottom 1/4 of the picture was black and white (no noise) and kinked too.

I tried several tapes but they are all the same and so were new recordings. I bought a VHS head cleaner at the weekend and now new recordings are nearly right but crackle and jump horizontally a lot but old recordings are still the same.

Any ideas?

Wondering what the online firm I bought it from would do now as it was only £100 and it'll cost them to send someone out.

:rolleyes:
 

MarkE19

Moderator
I would suggest you try and unplug it for about an hour to let it cool down and loose any electricity that is stored in the VCR. Then plug it back in and see if it now works from cold.

If that fails then I would think that to get a repair/replacement you will have to box the VCR up and send it back to the e-tailer you bought it from. Small electrical items are not normally covered by an onsite warenty.

Mark.
 

Damian1978

Well-known Member
Well I left it unplugged all last night. Plugged it in a few minutes ago but not had chance to try it again yet though.

I have the box and all the bits.....it still looks new too. :(
 

The latest video from AVForums

Podcast: CES 2021 Special - Sony, LG, Panasonic, Samsung, TCL and Hisense TV news and more...
Top Bottom