1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Faulty Nad 320BEE amp... what can i do?

Discussion in 'AV Receivers & Amplifiers' started by the_dead_parrot, Apr 25, 2003.

  1. the_dead_parrot

    the_dead_parrot
    Member

    Joined:
    Apr 16, 2003
    Messages:
    107
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Rugby, Warwickshire
    Ratings:
    +0
    Hi got a nad 320bee amp and as finally my speakers came io got to try my whole system out for the first time fully, connected it all up turned it on... only output from one speaker, woooops i thought maybe iv not connected it right, so i take all the connectors out the back of the amp, tighten the wires up a bit more and push them in further, turn it on again still only putput in one speaker... the balence is in the centre... lol i made sure... iv tried both the speakers with both different cables on the right speaker output and it all works, but try either speaker with either cable on the left output and it doesnt work... the only way i get any sound is if i turn it up full blast with the balence fully towards the left speaker... and then its only a little noise... does this mean the amp is faulty? or is there anythig else it could be

    my system is listed below...

    thanks for any help
     
  2. buns

    buns
    Banned

    Joined:
    Apr 29, 2001
    Messages:
    6,066
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    58
    Location:
    Belfast
    Ratings:
    +1
    I got this with an old marantz amp a few years back..... dont know what it was but it was a fault of some sort. Take it back and get it fixed or bitch and have them replace it to make sure you get a good'un!

    ad
     
  3. sounddog

    sounddog
    Well-known Member

    Joined:
    Dec 11, 2002
    Messages:
    3,373
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    107
    Location:
    Leicestershire, UK
    Ratings:
    +461
    Have you tried swapping the left and right connectors on the input to the amp??

    Vikki
     
  4. the_dead_parrot

    the_dead_parrot
    Member

    Joined:
    Apr 16, 2003
    Messages:
    107
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Rugby, Warwickshire
    Ratings:
    +0
    erm.. do you mean have i tried the left speaker on the right output and the right speaker on the left output? or are you talking about something different?... as iv tried both speakers on both left and right outputs
     
  5. buns

    buns
    Banned

    Joined:
    Apr 29, 2001
    Messages:
    6,066
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    58
    Location:
    Belfast
    Ratings:
    +1
    id kinda assumed that..... but Vikkki means to try connecting your cd player the opposite way round..... connect the cd player right to amp left and cd player left to amp right....... I presume!

    ad
     
  6. the_dead_parrot

    the_dead_parrot
    Member

    Joined:
    Apr 16, 2003
    Messages:
    107
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    16
    Location:
    Rugby, Warwickshire
    Ratings:
    +0
    yes it works, it tried changing the l to r and r to l it didnt work coz my homemade interconect seems to be buggered, tried it with another one of my interconnects and it worked first time, thanks for your help yey got a working sytstem... top class thats two stupid problems iv been helped out wih on here... il be getting a reputation
     
  7. sounddog

    sounddog
    Well-known Member

    Joined:
    Dec 11, 2002
    Messages:
    3,373
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    107
    Location:
    Leicestershire, UK
    Ratings:
    +461
    Hey don't beat up on yourself parrot ... we all have to learn sometime and even the most experience of us have to be reminded to check the simple things at times.
     
  8. buns

    buns
    Banned

    Joined:
    Apr 29, 2001
    Messages:
    6,066
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    58
    Location:
    Belfast
    Ratings:
    +1
    just like i did in neglecting that point! :D

    ad
     

Share This Page

Loading...