1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Faulty iScan Ultra Maybe?

Discussion in 'Projectors, Screens & Video Processors' started by themmings, Jul 9, 2004.

  1. themmings

    themmings
    Active Member

    Joined:
    Nov 21, 2002
    Messages:
    380
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    21
    Location:
    Northampton
    Ratings:
    +4
    Hi folks.

    Is there any iScan Ultra experts out there?

    I've had mine for about 18 months. I run my SKy+ box through it and output the signal to my Pioneer 433MXE plasma screen via VGA high quality cable (sky+ goes out via VGA and then gets converted to component via my JSimms box).

    I used to be very happy with the image via sky, but recently I've not been happy with the picutre. Basically when you watch football or moving images you get this horrible comet trail, stiller images don't seem what they used to be either (more pixelated and trails to a certain degree too).

    I run my Arcam DVD player (DV88) through the iScan Ultra and the image seems fine. But Sky is poor.

    The other thing that makes me think there's a fault with my iScan is that I can't pull the 'Picture' function up on the display window any more (either by remote control or manually on the front of the unit).

    The thing that puzzles me though, is that it is giving me some functionaility - i.e. toggling and passing a signal from both component 1 and component 2 (sky source / DVD source)????

    I'd of thought that if it was to go pop - the whole thing would go pop and you'd not be able to run any signal through it.

    It definately seems to have lost some processing 'omphhh'.

    Any help would be greatly appreciated.

    Thanks, Tim :)
     
  2. Joe Fernand

    Joe Fernand
    Distinguished Member AVForums Sponsor

    Joined:
    Jan 20, 2002
    Messages:
    24,073
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    166
    Location:
    The Borders
    Ratings:
    +2,529
    themmings

    What does the 433MXE think its seeing - Interlaced or Progressive; possibly the signals getting through the box but no processing is being applied.

    Use the 'Display' button on the MXE remote and the screen will flash up info on the signals its receiving.

    Best regards

    Joe
     

Share This Page

Loading...