Fault with my new CA 640C

Discussion in 'Hi-Fi Stereo Systems & Separates' started by Jim Lad, Nov 28, 2004.

  1. Jim Lad

    Jim Lad
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Just been down to RS today to purchase a CA 640C to go with my 640R receiver and already it seems to have a fault. This isn't the hum that some people have described its a really annoying and loud high pitched noise heard in between some tracks. Doesn't happen between every track, just between certain tracks on different cd's. Its repeatable and will do the same thing between the same two tracks each time.

    Was just wondering if anyone else hear has experienced this same sort of problem, with the 640C or with any othercd player. Bit miffed really as I'm impressed by the sound otherwise ;-/

    Cheers

    Jim Lad
     
  2. Ed Selley

    Ed Selley
    AVF Reviewer

    Joined:
    Jun 26, 2003
    Messages:
    11,195
    Products Owned:
    1
    Products Wanted:
    2
    Trophy Points:
    166
    Ratings:
    +3,667
    There appears to be a batch problem with the transformers at the moment so I would wait a little (perhaps informing the store you intend to do this) and change toward the end of the month.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice