farcry patch

dennis

Active Member
i had to re-install farcry,and now i cant install the patch!,it comes up with something like"you have deleted a previous game that had the patch install,please remove all traces,if i do what it says it comes up with a fatal error code!what the fudge is going on:suicide:
 

The latest video from AVForums

Podcast: REL T9/X Subwoofer + Bowers & Wilkins PI7 Reviews, AV Shows in a Pandemic and more
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom