Factory refurbished amp

archer66

Active Member
Hi All, after your thoughts/oppinions, have seen an add on ebay from hyperfi for factory refurbished Onkyo 875 with a 12 month Onkyo warranty for £499, has anybody ever purchased a factory refurbished receiver if so what are your thoughts good or bad please, I already have an 876 for my main room but am after one to run a pair of RS8's in a second room, thanks for your views.
 
A "Factory Refurb" to me means as good as new. However, it begs the question why did it need a refurb?

I could be it went bang or conversely just had a cosmetic blemish on the front panel.

If the saving is good and it comes with a full warranty I would be tempted.:smashin:
 

archer66

Active Member
Hi Will

Thanks for the reply, it is not so much the saving as you can't get the 875/876 anymore and I am told the replacement for the 876 is not as good, it is £200 cheaper than I paid for my 876 which was a good deal in the first place but that did come with a 3 year warranty and funny enough it is away being repaired now LOL, where as these only come with a 12 month warranty.
 

kbfern

Distinguished Member
I have been looking at these myself and am tempted @£499 although the shipping is a bit steep at £35.

Like you I am a little worried as to how blemish free they are and why were they sent back for refurb in the first place.

Still as has been pointed out they come with a 12 month warranty so if any prob's at least you don't have to worry for the first year.

As a matter of interest what's wrong with your amp and has it been trouble free other than this fault.
 

archer66

Active Member
I have been looking at these myself and am tempted @£499 although the shipping is a bit steep at £35.

Like you I am a little worried as to how blemish free they are and why were they sent back for refurb in the first place.

Still as has been pointed out they come with a 12 month warranty so if any prob's at least you don't have to worry for the first year.

As a matter of interest what's wrong with your amp and has it been trouble free other than this fault.

Hi although I have had my 876 for 6 months it has only just been set up and the fault found straight away but due to the time I had had it I could not get it replaced so it has gone for repair. The fault with it is cutting out when playing bluray through it at a reasonable volume.:thumbsdow Should have tested it properly when I purchased it not waited 6 months.
 

The latest video from AVForums

Are the TCL MiniLED TVs better than OLED? TCL Interview with Marek Maciejewski | AVForums Podcast
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom