External HD not recognised by PC

Discussion in 'Computer Components' started by davytv, Feb 12, 2009.

  1. davytv

    davytv
    Standard Member

    Joined:
    Sep 30, 2008
    Messages:
    13
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I recently bought an Iomega 250GB external hard drive to back up my files.
    I plugged it into my USB and started transfering the files in batches with no problems apart from the transfer time being rather slow. (a message popping up saying it would be faster connected to a USB 2.0 - which I though my USB's were?!).
    But the files transfered. The next time I tried to continue to transfer, the External HD is not recognised in My Computer!
    I've tried going through Device Manager with everything apparently working properly!
    I've looked around this and other forums and noticed formatting NTFS 0r FAT32, but really no idea what to do. I thought the external HD would just plug in and play!
    Any advice please!
    Thanks
    Davy
     
  2. Trollslayer

    Trollslayer
    Distinguished Member

    Joined:
    Feb 11, 2007
    Messages:
    26,092
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    166
    Location:
    Poole
    Ratings:
    +10,948
    It may be some ports are 1.0, try another block of ports.
     
  3. Mr Lazy

    Mr Lazy
    Active Member

    Joined:
    Jan 14, 2008
    Messages:
    1,026
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Rochester, Kent
    Ratings:
    +144
    Tried a different USB cable?
     

Share This Page

Loading...