1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Epson TW10H power supply problem.

Discussion in 'Projectors, Screens & Video Processors' started by Ewan, Oct 27, 2004.

  1. Ewan

    Ewan
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi!
    Sorry to post so many threads. My Epson TW10H pj came today. I'm very happy with it-been watching DVDs all day.

    There is only one problem I have found with the pj. The power cable that goes into the back of the pj does'nt seem to fit very well. It keeps falling out. It not a very good fit.

    Silly question-but should I send it back?
     
  2. RichMercer

    RichMercer
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    That's definately not a problem on all of them. My power cord fits in quite tightly. The question is, why is yours loose? Is it the cable or the pj? I would be inclined to say the cable, but if you send it back or not is up to you. Surely you must have another similar cable somewhere in the house you could use to test it? If it is the cable, I would just replace that, else, send it back. I think if you go through Epson, they do a next day replacement so you wont be without it for too long that way.

    BTW, how are you finding it? Please with your purchase?
     
  3. Ewan

    Ewan
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi!
    Thanks for the reply :) I'm very pleased with it :thumbsup: it money well spend.
     
  4. Delh68

    Delh68
    Active Member

    Joined:
    Dec 13, 2002
    Messages:
    1,015
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    48
    Ratings:
    +52
    I agree with RichMercer - the power cable is a tight fit on mine also (was very difficult to get in, are u pushing it in firmly enough?, as i had to 'shove' quite hard to get a tight fit)
    U may be getting a contact, enough to power it, but need to 'see it home' to get it snug.
    Otherwise, it does seem odd.

    Delh68
     
  5. PjPip

    PjPip
    Active Member

    Joined:
    Jun 16, 2004
    Messages:
    267
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Ratings:
    +7
    Agree with the others, perhaps even unusually tight fit.
     
  6. johnniekipper

    johnniekipper
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Ewan,

    Mine has the exact same problem. The first day I used it the cable fell out a few times mid use (not good for the projector) I might ring Epson about it. So your problem is not a once off.
     

Share This Page

Loading...