Epson R300 not printing from Word and USB MFP error

8

888

Guest
Anyone had similar problems?

1. Not being able to print from MS Word (but prints from Espon's own photo software and Windows test page). The older printer attached to the LPT works fine.

2. In device manager the printer is listed as USB MPF device with ! next to it. All other USB devices works fine.

I'm running Win 2000 SP 4. I've tried this printer on 2 different PC's and got same result (a Mega PC651 Intel based and a Shuttle SN41G2 AMD based).

Epson technical support in UK is near to useless. After researching the web for 2 days I've only found one post of someone with a similar problem.
 

RobertP

Standard Member
Having a few minutes to kill I Googled your problem.
Came up with this groups search where the last hit mentions your printer and partially installed drivers.

The two comments that may be relevant are that the drivers must be fully installed with the printer not plugged in first... then the printer connected, and that MFP is usb 2.0 high speed only not usb 1.

Hope that helps rather than just adds to your problems :)

you may have already tried the groups search... it's where I go first when I have a problem to sort out.
 
8

888

Guest
I've tried all of the above. To no avail. I tried 2 other PCs at work by downloadng the latest driver from the web. XP worked first time, and to my surprise so did the Win2K PC. This really got me going.

Got home uninstalled the Epson !"£$^& off and installed the download driver. To my surprise it asks for CD. I hit cancel as the 2 PCs at work did not request this so I guess there is still residual Epson £$%^^& on my PC. Device manager still shows !, but everything work. printing from Epson Quicker, Word browser etc.

However, when I re-booted my PC still asks for the Epson CD. Otherwise everything works (! still on device manager)

My guest is the CD that came with the printer is a load of £$^$^*&. And the device drivers are poorly written. And I can't get rid off the original s/w.

I'm temped to upgrade the OS to XP. I loathed to do this because I'm not impressed by XP at all, but I do beleive the driver support is better.

Thanks for the help. I'll post an outcome. Still tempted to throw the thing through the shop window.
 

melliott1963

Novice Member
Sounds like you've had the same experience as I had with my Epson printer a few years ago. I eventually dumped it and bought a Canon and haven't looked back since.
 
8

888

Guest
melliott1963 said:
Sounds like you've had the same experience as I had with my Epson printer a few years ago. I eventually dumped it and bought a Canon and haven't looked back since.
I eventually solved the printing issues by uninstalling as much of the Epson cr#p as possible. Download the latest device driver from Epson website (just driver only nothing else) and turning the offer to re-install the drivers from CD when prompted. However, the ! is still there and everytime the printer starts up it asks me to put in the original CD. Pressing cancel gets rid off the prompt and things continue to work.

I beleive the CD drivers were rubbish and it was never rectified probably.

The most bizzare thing with all of this is not my printer. I just brought it for a friend against my advice of photo printing at home which is very expensive. Even though I was impressed with the photo quality when printed on preimum paper.
 

The latest video from AVForums

Podcast: Reported HDMI 2.1 bugs, Audiolab Amp & LG LED Projector reviews + Best of the Month
Top Bottom