Epson 8500UB HDMI issue

Discussion in 'Projectors, Screens & Video Processors' started by NYDennis, Aug 5, 2013.

  1. NYDennis

    NYDennis
    Active Member

    Joined:
    Mar 14, 2012
    Messages:
    76
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    8
    Ratings:
    +5
    Hi all,

    I had a Pioneer SC-37 and have an Epson 8500UB. 50' cable. Recently I had an issue where on both units the HDMI 1 ports stopped working. I assume some sort of power surge? In my testing I was able to get the HDMI 2 port on the projector to work with the 50' cable.

    I bought a new receiver today. Sony ES receiver. Hooked up teh 50' cable and getting nothing (tried two 50' cables) from HDMI 2. I tried both 50' HDMI cables into a TV instead of the projector and both cables worked fine into the TV.

    I then took a short 6ft cable and plugged it into my Dune Media player that I moved closer to the projector for the test. That worked fine on HDMI 2. Still nothing from HDMI 1.

    I have a MACK warranty on the projector and was just going to live with it on HDMI2, but I wanted to see if anyone had any ideas first.
     
  2. Rajul D

    Rajul D
    Novice Member

    Joined:
    Dec 18, 2013
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    hi Dennis, i recently faced same issue after purchaisng it in Mar-11. i also use Pioneed SC-1522/SC-57. my HDMI sources on 8500UB stopped working at once. no luck with different, short cables or with sources directly connected to proj. Epspon has directed me to auth service companies for repair at my own cost. so..
    1- could you fix this HDMI issue somehow?
    2- any way to purchase and replace HDMI board on my own?
    3- what is cheapest way to replace HDMI board?
     

Share This Page

Loading...