Epson 6000 warm up lamp blinks but no main lamp ignition?

Galaxy

Active Member
My replacement 6000 arrived on Thursday (first projector had a lens error) thurned it on the very first time and checked the lens, looks much better on this example, but on turning it on later that evening to watch a film the lamp would not ignite, the warm up lamp was blinking for about 10 minutes before I gve up and unplugged the mains lead, power back on and still a blinking lamp with no main lamp ignition, after about three complete power downs (power lead out) it finally lit up, almost immediately after pressing the remote!
Tried it again today and its been sitting there now for 15 minutes, nothing just the blinking lamp......no fan noise either, tried the power trick and still just blinking again......I am getting a bit worried about these Epson projectors now, this is the second with problems straight out of the box.

Looks like another phone call to SuperFi on Monday! They have been more than helpful so far......but I am not sure I really want to carry on with this Epson malarky

I did a search in here for warm up lamp blinking but found nothing, any one else read anything about this? Can it just be me?
 

Galaxy

Active Member
Well for the past 2 hours give or take a few minutes I have been trying to get the projector to turn on, but nothing....just the blinking warm up lamp, it appears I now have a very pretty piece of Japanese sculpture hanging on my wall that resembles a attempt at electro mechanical hi-tech engineering....which fails miserably! :mad:

It appears my parrot is dead!
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom