Emtec S800 -trouble with Firmware update

yytsunamiyy

Standard Member
I recently purchased an EMtec S800 Movie Cube. As I like to do with new systems I buy i want to make sure the latest firmware is installed. Only problem is- i can't even figure out which is the current version installed. In the info menu it shows 6.2.1262UO(751) which bears no resemblance to anything on the EMTEC Firmware download site (S850H/S800H/S700H - HDD Multimedia player & recorder | EMTEC).

I figured I should just go with the latest firmware update (r4681). I followed the instructions in the manual, downloaded the bootlader upgrade (..1026), extracted the 2 files to the root of a FAT-Formatted USB drive, plucked it in one of the USB-HOST slots, pulled the Power cord, pushed and held the standby button, replugged the power cable, kept on holding the standby button to a count of 20, and released it.

Trouble is - nothing happened. No Installation screen appeaered, no LED blinking - nothing but normal operation (Standby red, blue line, Emtec Logo showing on the lcd screen).

What am I doing wrong? And do I even need a Firmware update? Thanks in advance for any suggestions.
 

boxer29

Novice Member
the fm which you are trying is for the emtec s800h ,,not the s800
thats why its not allowing you to put this fm on ,,i think the latest official fm for the emtec s800 is 905 if i might remember correctly
have you read through the forums have a read through here
S800 in English [Forums] : MHDWorld for Emtec

if you are using a emtec s800h ,,stress is on the H WHICH STANDS FOR HD
then you first need to install the boatloader ,,both files need to be in the root of the usb and dont unrar the 2nd file it has to be as it is ,,
then insert the usb which has got the files on ,,keep holding the power button at the front ,,and put the power lead in ,,keep presing the power button for more then 5 sec and then leave it ,,the box will reboot and install the new bootloader ,,then you can install the new fm which is r5215 ,,you can also download the fm from the above link
 

yytsunamiyy

Standard Member
Those who are able to read do have an advantage in life. I tried indeed installing the fw for the S800H on an S800 - no wonder it didn't work. worked fine with the fw for the S800. Thank you.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom