Question EMOTIVA XPA 5 (GEN1, HELP!)

Discussion in 'AV Pre-Amp/Processors & Power Amps' started by mkohman, May 3, 2016.

Tags:
  1. mkohman

    mkohman
    Well-known Member

    Joined:
    May 14, 2009
    Messages:
    2,438
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    117
    Location:
    London
    Ratings:
    +896
    Hi Guys,

    I have had my Emotiva XPA - 5 since August 2012 and had absolutely zero issues since day one.. This evening I sat down to watch a movie and 10 mins in , the 5 x blue led lights on the front panel switched out, the sound went on my speakers and two red lights on the front started to flash. I immediately went over to my XPA 5 and turned it off. When I switched it back on a few mins later the 5 x lights cycled as usual on start up (in red) and then all became blue .. It was as if nothing had happened, however this time there was no sound coming from my main 5 x speakers, which is powered by the XPA - 5.

    I have an atmos set up with dual subwoofers (5.2.4) , the other 4 x speakers are all powered with another power amp. I have chop and changed all my XLR cables as I was worried that it may have fried my speakers but luckily touvh wood all good as they all work with the other power amp. I have spent hours trying to figure out what it may be and it is definitely the XPA 5
    -
    The weird thing is, when powered all the led lights go blue which is fine but there is no sound at all coming from my main 5 x speakers. I have unplugged the xlr cables and the speaker cables and powere the XPA 5 with nothing other than the power cord and again all blue so seems like it has no issues but no sound from my speakers. So I pulgged then amm in one at a time , turning the XPA 5 on and off each time but again .. no joy .. no sound..

    100% something is wrong with the XPA 5 , I am not sure what though as all the led at the front is blue??? The one thing I have not done it to try to connect to my Anthem with a RCA cable after this issue rather than xlr.. Could it be possible that the XLR terminals have developed a fault?? I doubt it but maybe worth a try to try with RCA see if sound comes out my speakers..

    Can anyone please advise me what may be the problem.. also am I still covered under warranty..? I'm absolutely devestated as I had this imported to me to the UK and love it to bits.. It's the heart of my cinema room and now doesn't want to play nice :(

    Thanks for all your help and advise...
     
  2. JimmytheSaint

    JimmytheSaint
    Active Member

    Joined:
    Mar 21, 2003
    Messages:
    1,793
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    London
    Ratings:
    +100
    Give the chaps at Emotiva a call and they will run through the symptoms and possible solutions with you. I once had a fuse blow on mine and they sent it out with instructions for free.
     
    • Like Like x 1
    • Agree Agree x 1
    • List
  3. fayeanddavid

    fayeanddavid
    Well-known Member

    Joined:
    Sep 23, 2009
    Messages:
    5,507
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Bearsted Kent
    Ratings:
    +1,920
    Absolutely agree with Jimmythesaint.
    Customer service is very good and I guarantee they'll have the answer/solution/ and possibly hardware in the post before the end of the call!!!
     
  4. mkohman

    mkohman
    Well-known Member

    Joined:
    May 14, 2009
    Messages:
    2,438
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    117
    Location:
    London
    Ratings:
    +896
    Thanks for all your help guys.. Panic over lol :) I called Emotiva who were very helpful and sent me a very informative .pdf file which explained where to find the fuses it was so simple and easily spotted the fuse in slot 2 was blown so a quick visit to maplins and bought a new fuse.. Changed it and now as good as new .. Thanks guys :)
     
    • Like Like x 2
    • Useful Useful x 1
    • List
  5. fayeanddavid

    fayeanddavid
    Well-known Member

    Joined:
    Sep 23, 2009
    Messages:
    5,507
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Bearsted Kent
    Ratings:
    +1,920
    Great news and great guys to deal with!!
     
  6. pressure

    pressure
    Active Member

    Joined:
    Dec 4, 2006
    Messages:
    899
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Sheffield
    Ratings:
    +412
    Wow that's a really encouraging post! Great to hear that Emotiva still do great support so long after initial purchase. :)
     
    • Like Like x 1
    • Agree Agree x 1
    • List
  7. Deleted member 598831

    Deleted member 598831
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Its very nice to feel they still give great back up.......even after initial purchase........when some uk outlets don't!
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice