Elgato Game Capture HD - edit mode play head locked


Novice Member
I have been utilizing Elgato "Game Capture HD" devices to digitize VHS tapes. Seems to work well, some of the time. However, there is an intermittent issue.

I capture the video with the "Game Capture HD" app. The capture is successful. However, afterwards when I click the "Edit" tab, I encounter the quirk. I can play the recent capture. However, in the timeline along the bottom of the window, the play head does not advance to match the video that I am watching.

Furthermore, I cannot manually position the play head. It is stuck at frame #1. Thus, without the ability to move the play head, I seem unable to cut out undesired segments.

  • App: Elgato's Game Capture HD 3.70.55(3055)
  • Operating system: Windows 10 Pro, version 21H2
  • Capture hardware: Elgato Game Capture HD, 2GC309901000
  • Processor: Intel Core i7
  • Memory/RAM: 8GB

Game Capture HD settings:
  • Library location: external USB SSD
  • File export location: external USB SSD
  • Disabled Flashback recording (adjusting this did not help)
  • Disabled Stream Command (adjusting this did not help)
  • Disabled "Always convert new videos to MP4 file (adjusting this did not help)
  • Input device: Other
  • Video input: Composite
  • Audio input: Analog Audio (Game Capt...
  • Profile: Standard
  • Cropping: None
  • Convert Standard Definition to 640x480 - YES
  • Stretch Standard Definition Input - NO

Basic troubleshooting that has failed:
  • Exit and relaunch app.
  • Restart computer.
  • Check for Elgato updates (none available).
  • Tried capturing to a different SSD.
  • Tried capturing with a different computer.
  • Tried capturing with an identical Elgato Game Capture HD device.
  • Relocate the SSD to a different computer and view with Game Capture HD on that other computer. The problem follows the captured video.

I am seeking both (A) ideas to prevent the issue from happening again and (B) ideas for how to make the existing problematic captures fully functional within the Game Capture HD app.

Or, is there a better forum for this issue?


Novice Member
Update: There appears to be a fix to restore a problematic video to full functionality.

1) Select the entirety of the problematic video in the timeline. (Click it once within the timeline, then press CONTROL-A to ensure everything is selected.)
2) Right-click the video within the timeline, then select "New Video from Timeline Selection" within the contextual menu that appears.
3) A new capture appears in the list of videos at right. The new version with a "Clip 1" suffix should be fully functional.

I remain interested in other feedback, particularly how to prevent the problem from happening again.

The latest video from AVForums

Samsung QN95B 4K QLED TV Review
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom