electrohome ecp3100 fault

Discussion in 'Projectors, Screens & Video Processors' started by micksahippy, Sep 3, 2005.

  1. micksahippy

    micksahippy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i have a problem with my pj, it was working ok until my brother cracked the front glass on the blue tube. .
    i have now replaced the glass, i removed the tube to do this but now when i try to power it up it seems to be ignoring the remote control,it will eventually come to life,fans running but no way can i get any light from any of the tubes.
    the projector had no power at all for about three weeks.
    any ideas?
    thanks in advance.
     
  2. bxd

    bxd
    Active Member

    Joined:
    Oct 17, 2001
    Messages:
    1,487
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Location:
    Southampton
    Ratings:
    +134
    Hi,

    In your efforts to remove/replace the tube you may have upset the board connections. You might try removing all of the boards (one at a time) and then replacing them 'firmly' back into their slots.

    You might want to replace your brother as well !!

    Welcome to the forums,

    Brian
     
  3. micksahippy

    micksahippy
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    i'll give it a go , but i don't think my mum will be happy :)
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice