Electrical fault while idling (ford Focus C-Max 2.0L TDCI)

Discussion in 'Motoring' started by isak, Aug 28, 2013.

  1. isak

    isak
    Standard Member

    Joined:
    Jun 4, 2013
    Messages:
    43
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Ratings:
    +0
    Hi all

    Never expierenced such an issue!!! I had a problem with my EGR valve and been to garage which confirmed its the issue by plugging in a diagnostics tool but several months later my car started to idle badly and after some fault finding i noticed when i turn my aircon/radio off before i start the car its fine?????! Turn the car off with radio or fan on then issue is back again!!!

    What can this be??? Its a Ford Focus C-Max 2.0L TDCI 54 plate
     
    Last edited: Aug 28, 2013
  2. isak

    isak
    Standard Member

    Joined:
    Jun 4, 2013
    Messages:
    43
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Ratings:
    +0
    The car wont idle more than 2000rpm but after awhile with smoke (grey) coming from exhaust then with foot slightly on pedal it will regain reffs????
     
  3. Simian Sibling

    Simian Sibling
    Well-known Member

    Joined:
    Jan 18, 2005
    Messages:
    6,579
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    Brentwood, Essex
    Ratings:
    +1,181
    Could be an injector? I had one go and I got a ruff idle. Get it pugged in again and that should tell you?
     
  4. isak

    isak
    Standard Member

    Joined:
    Jun 4, 2013
    Messages:
    43
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Ratings:
    +0
    Thanks, it was my EGR and sensors as im still in the cleaning process. Will use EGR cleaner soon
     

Share This Page

Loading...