Echo dot will not connect to home WiFi

RobMcM

Active Member
We just got given an Amazon Echo Dot (4th Generation), and I have spent all day trying to get the little sod to connect to my home WiFi. Will it? No. Most of the time it just times out, other attempts get the response that the password is incorrect (it isn’t).

Most frustrating of all is that it will connect absolutely fine to other WiFi networks - I’ve tested it with hotspots from my iPhone and android phone and it’s fine. But my home network is a no-no.

Does anyone have any idea why? I’m using Three 5G home broadband, and the router is a HUAWEI 5G CPE Pro. All my other devices have connected fine… just not this.

Finally, and don’t know if it’s significant, I also tried to add an old router as a WiFi extender today. I’ve done this a thousand times before while with Virgin Media and it’s worked every time. This time, while I could still access the internet through the slave modem, it didn’t seem to be getting an IPv4 address from the Huawei. Could the 5G router be at capacity? Hope not - that would be extremely limiting if it was!
 

Seb Briggs

Distinguished Member
Likely to do with the dual band 2.4ghz and 5ghz , echo only uses 2.4ghz so you need to check this is turned on and using the same credentials
 

Seb Briggs

Distinguished Member
Sorry I’m wrong there it can connect on both however when setting it up on a phone ensure both devices are using the same band ie 2.4 or 5ghz
 

DJDave87

Active Member
Change the name of your personal hotspot on your phone to the name of your wifi and use the same password. Then turn off your personal hotspot and with any luck itll jump on to the wifi network.
 

RobMcM

Active Member
Change the name of your personal hotspot on your phone to the name of your wifi and use the same password. Then turn off your personal hotspot and with any luck itll jump on to the wifi network.
This is a great idea! I’ll try this one later. Thanks in advance!
 

Trajet

Active Member
Change the name of your personal hotspot on your phone to the name of your wifi and use the same password. Then turn off your personal hotspot and with any luck itll jump on to the wifi network.
That is a great tip. I've saved it for future reference. The amount of times I have had to disable 5ghz to add a 2.4ghz only device before re-enabling 5ghz has been frustrating.
 

The latest video from AVForums

Podcast: Panasonic JZ2000 Final Thoughts - TV Calibration: Should you? And More...
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom