Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

DVD Playback Problems

Discussion in 'Desktop & Laptop Computers Forum' started by ajbeech, Jan 8, 2003.

  1. ajbeech

    ajbeech
    Standard Member

    Joined:
    Jan 7, 2003
    Messages:
    57
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    6
    Ratings:
    +0
    Hi All,

    Can anyone offer any advice?

    I've recently been turning my PC into a mini home cinema setup. The basic spec of my PC is as follows:

    ABit KT-7A Motherboard + latest VIA drivers
    512 mb RAM
    Windows XP Pro
    Creative Geforce4 Ti4600 video card
    Creative Audigy2 Platinum sound card
    Creative Inspire 6700 Speakers (6.1 surround)
    I use PowerDVD XP 4.0 as the DVD player.
    The DVD player is set to DMA

    The problem I am experiencing is somewhat choppy video playback - its watachable, but looks bad when compared to my standalone DVD player. My PC setup should be more than capable of decoding DVDs and I can seem to locate the problem.
    I have no other problems with the PC - it runs anything thown at it, including the latest 3D games (with all settings maxed out).

    I intend to try another software player this evening to see if it makes a difference, but I'd be grateful to hear from anyone who has had similar problems and solutions used!

    Thanks,

    Andrew
     
  2. Lithian

    Lithian
    Standard Member

    Joined:
    Jan 16, 2003
    Messages:
    38
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    9
    Location:
    Edinburgh 3
    Ratings:
    +0
    Hmm, no-one replied to this post, i found it when searching for something so if i am repeating something please excuse me.

    Switch the DVD-rom drive off of DMA, i know this sounds strange. You would think that DMA would improve the scenario.

    Try it, disable DMA.

    Simplest way to do this.

    Hit 'windows key'+ 'Pause break' (its the system control panel)
    select device manager
    select cd-rom
    select your DVD-Rom drive
    hit properties
    select settings
    unselect DMA

    try it out.

    enjoy.
     
  3. Comer

    Comer
    Active Member

    Joined:
    Sep 21, 2001
    Messages:
    1,384
    Products Owned:
    1
    Products Wanted:
    0
    Trophy Points:
    51
    Location:
    Ireland
    Ratings:
    +85
    Firstly I would think that DMA should be switched on and in fact I think that this is automatically applied for windows XP anyway

    Try changing your refresh rate to 75hrz for Pal DVDs and 72Hrz for NTSC

    Conor
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice