DVD Audio stutter

jaymz

Novice Member
I am having serious problems taking DD or DTS audio from DVDs via my MCE machine. This worked a fews ok but i do not know what has changed :thumbsdow

The machine is connected to a Yam 657 via digital coaxial (i have tried digital optical with no difference) and receiver input display "flickers" between DD and DTS and causes the audio to "disappear" when changing between the two. The time it takes to "flicker" between the two is random and so is whether DD or DTS gives sound to the speakers. Whats even wierder is DTS appears on disks that do not have it on!!

PCM shows on the receiver but i am not sure if it should.

Config as below ;

Pure Video 81.89 set to SPDIF
Graphics drivers .223
SoundMAX Audio .4151
Ffdshow has AC3 & DTS set to SPDIF

Live TV works ok and the receiver converts stereo to PLii.

I think the issue is ffdshow is active when playing DVDs but Pure Video should be doing the audio (this is proven as ffdshow audio icon is task bar and Pure Video GUI does not have Audio settings).

I was thnking of using GraphEdit to check the filter chain but i am not sure how to?
 

jaymz

Novice Member
I have gone back to basics and checked the following;

SPDIF bracket is connected properly to mobo - yes
uninstalled ffdshow - still have problem
installed original soundmax drivers with mobo - still have problem

I have noticed that he Sondmax control panel has no SPDIF option that the help function should be there, can anybody confirm there is one?

I manged to get graphedit to work and the graphs are attached, for some reason there is two direct show filter chain when watching a DVD but only one when watch TV.
 

Attachments

jaymz

Novice Member
Just done some more testing and MPC and WMP10 have the same problem.

Looking closely at the receiver shows DTS and PLii iluminated at the same time so i assume its getting confused to what data stream it is recieving from the SPDIF out on the PC.
 

jaymz

Novice Member
Just reinstalled the SoundMax drviers again and noticed that the SoundMax software had no SPDIF option, should there be one?

Should there be any other items installed in Device Manager e.g SPDIF bracket controllers?

Any other ideas?
 

jaymz

Novice Member
I managed to do some more testing last night and have discovered the following;

DVD-writer was set to extract audio digitally, i have removed this and now do not get PCM on the receiver. Should this be off?

The DVD-writer is a Pioneer 111 and is set to auto dtect in the BIOS PIO and DMA modes. However device manager is set to auto detect (and is grayed out) and has selected PIO. Would this have any affect?

In device manager i also have a "MS UAA Function Driver for the High Definition Audio - Adi 1986" if i remove this i get no audio at all, should this be the case? Is this needed?

Reinstalled SoundMax again and still SPDIF option!
 

Cable Monkey

Novice Member
Extract audio digitally and find a way to force DMA mode, that should cure the stutter.
 
T

tomatoface

Guest
jaymz said:
I managed to do some more testing last night and have discovered the following;

DVD-writer was set to extract audio digitally, i have removed this and now do not get PCM on the receiver. Should this be off?

The DVD-writer is a Pioneer 111 and is set to auto dtect in the BIOS PIO and DMA modes. However device manager is set to auto detect (and is grayed out) and has selected PIO. Would this have any affect?

In device manager i also have a "MS UAA Function Driver for the High Definition Audio - Adi 1986" if i remove this i get no audio at all, should this be the case? Is this needed?

Reinstalled SoundMax again and still SPDIF option!
I had the same problem, this link describes it - it worked for me.
http://winhlp.com/WxDMA.htm
 

jaymz

Novice Member
Thanks Guys Sorted! :thumbsup:
 

Similar threads

The latest video from AVForums

The Best Movies and TV Shows Coming To Amazon Prime Video in August 2020. Tom's Thumbs.
Top Bottom