1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Dv88

Discussion in 'Arcam Owners' Forum' started by vlieg62, Jan 22, 2005.

Tags:
  1. vlieg62

    vlieg62
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi all,

    I own a DV88 from 2002 and have a problem. Suddenly the analoque/cd and the display are not working anymore. No sound nothing! Strange thing is the digital part (dvd, dolby digital coax) is working fine.
    In the service menu the DV gives the following errors:
    DV103 X
    ADV7196 X
    PSDRAM X

    X is for not working

    Anyone a clue what this can be?

    Regards,

    Paul
     
  2. nagrom

    nagrom
    Standard Member

    Joined:
    May 23, 2010
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    I have the same issue and symptoms. Did vlieg62 (or anyone else) find a solution?
     
  3. Mark.Yudkin

    Mark.Yudkin
    Well-known Member

    Joined:
    Sep 19, 2007
    Messages:
    9,841
    Products Owned:
    0
    Products Wanted:
    1
    Trophy Points:
    136
    Location:
    Zurich, CH
    Ratings:
    +1,491
    Sending it into Arcam for service?
     
  4. MI55ION

    MI55ION
    Well-known Member

    Joined:
    Nov 8, 2005
    Messages:
    5,810
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Ratings:
    +685
    Sounds like the DAC is fried, it'll cost approx £150 to get it repaired so not really worth it imo. Use it as transport only or get rid of it...
     
  5. nagrom

    nagrom
    Standard Member

    Joined:
    May 23, 2010
    Messages:
    2
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Many thanks for the feedback
     

Share This Page

Loading...