Dungeon Siege now flickers :( any one know how to fix this????

nero0410

Distinguished Member
As title

I haven't played Dungeon Siege in ages and decided to put it on my vista laptop that has a nvidia gf9500m gs, and it installs fine and plays ok, but the thing flickers all the time no matter what graphics configs and compatability modes that I try.

Has anyone else had this problem with vista and possibly know how to fix it??
(game is also patched up to the latest version)

Diablo II and other old rpgs play fine

tris
 

Knyght_byte

Distinguished Member
I dont have the game or the problem, but as an off the wall suggestion, try setting V-sync to on if you have it.
 

Rasczak

Distinguished Member
This is a graphics driver issue - I have seen the same thing in some other games - updating the graphics drivers has always solved it. What make of laptop do you have? Some companies will provide the driver updates on their websites, otherwise try the Nvidia drivers website.
 

nero0410

Distinguished Member
I dont have the game or the problem, but as an off the wall suggestion, try setting V-sync to on if you have it.

As far as I can tell, there appears that there is no v-sync setting anywhere, but still getting used to vista and a laptop:rolleyes:

This is a graphics driver issue - I have seen the same thing in some other games - updating the graphics drivers has always solved it. What make of laptop do you have? Some companies will provide the driver updates on their websites, otherwise try the Nvidia drivers website.

heh heh, an Acer:
Acer Aspire 6920G-583g32bn
intel core 2 duo t5800 processor @ 2.00ghz
3gb ram
vista home premium

The graphics are a geforce 9500m gs 512mb.
As far as I can tell from the acer downloads section of the site the driver is the latest version of what they support:
7.15.11.7561

Service & Support

I have tried the game on my main system, which has a sapphire ati 4850hd and it runs fine, but can't get it to stop fickering on my laptop:(
I have tried all variations of the video settings, inc resolutions as low as 640x480, and turningT&L off.

I have checked and found that there is a compatability issue with vista, but no solution there.

Anything else I can try??
Have been looking for a fan made patch just in case, but no luck

tris
 

Rasczak

Distinguished Member
The way I have got around issues like this - and I appreicate it is not for everyone - is to have a dual boot arrangement with Vista and XP. By having both my experience is one set of drivers will always work. For instance the last 'flickering' I had was with Doom 3 in XP - played in Vista it was fine.

On a wider issue (rant) I wish both Nvidia and AMD would bring there mobile graphics solutions into line with the desktops. At present mobile graphics drivers are often provided to the relevant laptop company and not released on the Nvidia/AMD pages. Trying to download the driver directly will lead to a limited feature set or the chip not being recognised by the drivers. It needs to be accepted that alot of gamers now play on laptops and thus graphics support needs to be regular and centralised. It seems pointless having the likes of Acer, Rock, Dell etc etc having to post GFX drivers - let's just have a single package available from Nvidia and AMD!

:lease:
 

nero0410

Distinguished Member
I did think of a dual boot system, but I am unable to obtain drivers for xp that actually function properly with the laptop :(
Was also told that if I use another operating system, it would void my warrenty (B£$&*^DS!!)

Both company's should have a driver specifically for their laptops GPU's on their site, surely they will have to do that eventually.

I presume the driver for my card that acer has on their site is definately the most recent?
It was developed dec 08

tris
 

blizzard

Banned
i get similar flicker in games on my vista laptop and my fix for it is to turn the right hand side clock off and its cured?

also theres a Vsync option in your nvidia drivers control panel.

:smashin:
 

nero0410

Distinguished Member
i get similar flicker in games on my vista laptop and my fix for it is to turn the right hand side clock off and its cured?

also theres a Vsync option in your nvidia drivers control panel.

:smashin:

I have had the right hand panel/clock etc.... turned off since I first set the laptop up, never could stand that rubbish.

I cannot see any options in the nvidia control panel, or drivers panel that are for Vsync at all??

tris
 

blizzard

Banned
Firstly go here and download and install this
GeForce Release 185

As its newer than acers!

I run a acer aspire 6935G with the 9600m GT graphics and those drivers are flawless. These drivers may fix the prob anyway.

once done and rebooted heres the option i was refering to




Let me know if you need further assistance.
 

nero0410

Distinguished Member
Firstly go here and download and install this
GeForce Release 185

As its newer than acers!

I run a acer aspire 6935G with the 9600m GT graphics and those drivers are flawless. These drivers may fix the prob anyway.

once done and rebooted heres the option i was refering to




Let me know if you need further assistance.

Is it going to be safe to do this on a laptop??
Will I be able to roll back the driver if needed??
Will it stop any other games/apps functioning as they do now??
Will I ever stop asking questions??

I ask as I don't fancy messing my laptop up and I know these company's have specific drivers for the cards in their laptops :(

Thanks

tris
 

blizzard

Banned
those drivers are for nvidia powered notebooks / laptops youll love em stop worrying :)

probs make other games run better , you may never stop asking questions as it's the only way to learn. Roll back is doable.

Blizzard
 

nero0410

Distinguished Member
those drivers are for nvidia powered notebooks / laptops youll love em stop worrying :)

probs make other games run better , you may never stop asking questions as it's the only way to learn. Roll back is doable.

Blizzard

oh and "company specific" drivers are actual Nvidia drivers with a tweaked inf file.

Ok thanks, downloading now. I'll let you know how I get on:thumbsup:

PS found that vsync option, and that didnt help :( Let's hope the new driver does:)

tris
 

nero0410

Distinguished Member
Fingers crossed :smashin:

Ran the installer (with adminstrator priv's), but just getting an error messege:
The contents of this file cannot be unpacked. The executable you are
attempting to run has been corrupted. Please obtain another copy of
the file, verify its integrity, and try again.

redownloaded this twice, but just appears to do the same thing :(

Any ideas:confused:

tris
 

blizzard

Banned
That message is indeed due to a corrupt download, im downloading it now and will check it and once i see its ok im more than happy to transfer it through to you via msn messenger if that's acceptable to you.

blizzard
 

nero0410

Distinguished Member
That message is indeed due to a corrupt download, im downloading it now and will check it and once i see its ok im more than happy to transfer it through to you via msn messenger if that's acceptable to you.

blizzard

Managed to get a working download this morning:thumbsup:

I have tried through all the options and resolutions etc.... again, enableing and disableing the vsync via the nvidia CP (both on the app it's self and on the glbal settings) and still get the flicker.

So I'm guessing it's just not possible to be played nicely on the laptop :(

Not sure if there is anything else to try now

tris
 

blizzard

Banned
Found this over at microsoft

Text or dialog boxes flicker.

To resolve this issue download the latest drivers for your video card, disable Hardware TnL or set the game to use blit mode.

To disable Hardware TnL: 1. Click Start, click Programs, click Dungeon Siege, click Troubleshooting, and then click Dungeon Siege Video Configuration Tool.
2. In the Video Driver drop down list, select "Primary Display Driver - Hardware"
3. Click OK.

To use blit mode: 1. Create a shortcut to the DungeonSiege.exe file.
2. Right-click the shortcut, and then click Properties.
3. In the Target field on the Shortcut tab, add the following at the end of the line: bltonly=true. The entire Target line would then read:
"C:\Program Files\Microsoft Games\Dungeon Siege\DungeonSiege.exe" bltonly=true
 

nero0410

Distinguished Member
Found this over at microsoft

Text or dialog boxes flicker.

To resolve this issue download the latest drivers for your video card, disable Hardware TnL or set the game to use blit mode.

To disable Hardware TnL: 1. Click Start, click Programs, click Dungeon Siege, click Troubleshooting, and then click Dungeon Siege Video Configuration Tool.
2. In the Video Driver drop down list, select "Primary Display Driver - Hardware"
3. Click OK.

To use blit mode: 1. Create a shortcut to the DungeonSiege.exe file.
2. Right-click the shortcut, and then click Properties.
3. In the Target field on the Shortcut tab, add the following at the end of the line: bltonly=true. The entire Target line would then read:
"C:\Program Files\Microsoft Games\Dungeon Siege\DungeonSiege.exe" bltonly=true

Damn, your as persistant as I was

I disabled the T&L before and it didn't work, but adding that line on the end of a newly made shortcut and running it from that done the trick:clap:

Thanks for the all the help and perseverance:thumbsup:

tris
 

blizzard

Banned
Hey were gamers persistence is everything trying to get a game running right.

Enjoy your gaming

Blizzard.:smashin:
 

kn0av

Novice Member
Hey, I see all those threads are from 2009, so 5 years have passed and I'm having the same problem as nero0410 was.

I've tried everything everyone said, im looking for solutions for the past 3 days and I can't find any.

I've already updated my driver, and I did as Blizzard told to do, yet the graphic just stay flickering everytime i move my camera around.

I'm running it on Win7, please, help?? D:
 

The latest video from AVForums

65-inch LG C1 Review coming soon to AVForums
Subscribe to our YouTube channel

Latest News

Sennheiser Consumer Electronics acquired by Sonova
  • By Andy Bassett
  • Published
Freeview Play viewers get Android TV homescreen update
  • By Andy Bassett
  • Published
Hisense announces US TV and soundbar ranges for 2021
  • By Andy Bassett
  • Published
AVForums Podcast: 5th May 2021
  • By Phil Hinton
  • Published
AVForums Movies Podcast: 4th May 2021
  • By Phil Hinton
  • Published

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom