1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

DON'T PANIC - The HS50 is fine!!

Discussion in 'Projectors, Screens & Video Processors' started by hebawom, Mar 17, 2005.

  1. hebawom

    hebawom
    Standard Member

    Joined:
    Apr 16, 2004
    Messages:
    187
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Matlock
    Ratings:
    +0
    Well I finally got my HS50 last night after about 6 weeks of waiting!! Over these 6 weeks I had plently of time to regret my decision at buying one, as many people were saying they had problems and were dissapointed with various things. One major thing people said was the light output on the HS50 was too low, well not for me!! I tried alot of the settings out last night, and it never seemed too dim, this was projecting on a cream coloured wall!!

    Also people were saying that it wasn't a huge step up from other projectors they had owned. These comments distract from the fact this is one great projector. Its a massive step up from the 2 projectors I've previously owned (a 4:3 data projector and before that a projector that had a built in video player - thats right V-I-D-E-O!!) The detail on this thing is awesome! I know all my comments will be a bit rose tinted because I only got it last night and was just totally in awe for the 2 hours I spent playing with it. Also I went to sleep and dreamt about it all night as well!!

    One thing I thought was superb was the ease of setup (what setup??) I turned it on, plugged in my computer and it found the signal, then I pointed the PJ at wall and used the lens shift to get it where I wanted - hey presto!! And lens shift - what an invention. I read about it previously, but I had no idea just how much you could shift it!!

    I wanted to post this so that people who have this model on order for a long time (like I did) won't start to stress about their decision. I'm quite sure you'll be more than happy with it.
     
  2. kikekun

    kikekun
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for your post.
    I ordered mine at the middle of february, and still no news of when I'm going to get mine :thumbsdow I'm a bit desperate now and was thinking in a) Get my money back b) Buying another projector ( in my case maybe the next Toshiba mt-700), but if you got yours yesterday maybe there is still some hope for me.
    My last info says that MAYBE I'll get mine at the end of March, but if it's delayed even a second more I'll go for another option.

    Can I ask where did you ordered your Sony?

    Thanks.


     
  3. hebawom

    hebawom
    Standard Member

    Joined:
    Apr 16, 2004
    Messages:
    187
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Matlock
    Ratings:
    +0
    Got mine from forum sponsors Discount electrical. I sent them lots of concerned emails regarding the length of time I had waited, they kept telling me they didn't know when they were getting stock from Sony, and then it just turned up out of the blue yesterday!

    Joy to the world!!
     
  4. r-06264

    r-06264
    Active Member

    Joined:
    Oct 4, 2004
    Messages:
    101
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Cape Town
    Ratings:
    +3
    Nottingham Hifi had one in stock on Saturday and it takes them 1 week to get one. Sony Centre told me 3 weeks. Demand is high for these things. All this problems with the HS-50 has put me totally off buying it though. Also had first hand experience with Sony Support last year and I wasn't impressed :thumbsdow
     
  5. kikekun

    kikekun
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0

    :clap: :rotfl:

    I hope mine turns out of the blue soon too! ;)
    Thanks, man.
     
  6. hebawom

    hebawom
    Standard Member

    Joined:
    Apr 16, 2004
    Messages:
    187
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Matlock
    Ratings:
    +0
    This is how I was feeling while I had one on order. But I think they have the problems sorted now - I don't know what firmware I have, or how to find that out, but I assume its the latest one. I really have no problems with mine. Also I hope I never have need to call Sony Support!!
     
  7. r-06264

    r-06264
    Active Member

    Joined:
    Oct 4, 2004
    Messages:
    101
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    18
    Location:
    Cape Town
    Ratings:
    +3
    Good luck then :) Hope you enjoy it. Keep us informed how it goes please!!
     
  8. paul1672

    paul1672
    Active Member

    Joined:
    Jul 31, 2003
    Messages:
    2,552
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    71
    Location:
    norfolk
    Ratings:
    +36
    i assume you dont have an hdmi dvd player then?
    shame,cause if you did the sure fire way to find out if it has the updated firmware is to connect the dvd player up via hdmi and then play a dvd through 720p.
    if its fixed the screen will view correctly,if it aint you'll have black border all way round picture.
    for what its worth i've had my hs50 for 2 months now and originally it was superb.
    now though its on its way back to be repaired.....
    hoping they'll update the firmware while its being fixed though.
    will be absolutely gutted if they dont though as it'll need to go back again if not....
    hope you really enjoy yours as when working its a smashing pj.
    paul
     
  9. hebawom

    hebawom
    Standard Member

    Joined:
    Apr 16, 2004
    Messages:
    187
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    19
    Location:
    Matlock
    Ratings:
    +0
    Paul, I don't have any HDMI devices, but do you know of any service menus where it might tell me what firmware it is? Also, how did you get on with calibration?
    I think I finished up my brief session last night with color temp medium, cinema mode, low lamp and auto iris.

    Forgot to say about the noise of this machine!!! Compared to my data projector, this is a night and day comparison. It makes such a difference to the enjoyment of the film
     
  10. paul1672

    paul1672
    Active Member

    Joined:
    Jul 31, 2003
    Messages:
    2,552
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    71
    Location:
    norfolk
    Ratings:
    +36
    regards finding out the firmware,i have no idea....
    mine is all packed up and ready to be returned today....
    i used the user 1 (with avia disc for region one films) and user 2 (with d.v.e disc for region 2 films) to setup my pj as i play a combination of region one and region two dvds
    to be honest,everyones machine wll be different so i can't really offer any advice other than what i've given.
    i have heard of people entering the service/factory menu's but i dont like that idea to be honest.
    sorry i can't help anymore.
    paul
     
  11. kikekun

    kikekun
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0

    You can find instructions to get to the factory settings HERE
    Just look on the 7th post I think.
     

Share This Page

Loading...