Dolby settings on amp and TV.

CharlySkunkWeed

Novice Member
Hi , this is my 1st post. I have the same issue as the OP .

Have a Onkyo surround sound amp , new 2tb wifi sky box and , Panasonic smart tv. My problem is my old sky didnt have hdmi Dolby so I bought an optical cable and all was fine. I just upgraded my Sky box which now has Dolby on both hdmi and optical . All my hdmi devices go to amp , then to tv , the optical only goes from sky to amp. When watching sky with amp on , any hd programs with Dolby being output obviously play through amp in Dolby. But if the amp is off and just using the TV speakers the HD dolby channels dont work yet the normal stereo ones do ! The only way to fix it is to change (on sky) the hdmi output to "normal" rather than "dolby" , but then if I turn the amp on its not Dolby anymore !
My old sky box worked fine with the optical. Amp on = Dolby , Amp off = tv speakers. So I assume its a setting on new Sky box thats causing this ?
If anyone has an Onkyo amp and a new Sky box , could you post up any settings relating to HDMI/AUDIO etc (whether they are optical/coaxial etc)
 

CharlySkunkWeed

Novice Member
Hi , this is my 1st thread. Found a thread on here with same issue but signed up just to explain my specific setup to tru to get a solution.
I have a Onkyo surround sound amp , new 2tb wifi sky box and , Panasonic smart tv. My problem is my old sky didnt have hdmi Dolby so I bought an optical cable and all was fine. I just upgraded my Sky box which now has Dolby on both hdmi and optical . All my hdmi devices go to amp , then to tv , the optical only goes from sky to amp. When watching sky with amp on , any hd programs with Dolby being output obviously play through amp in Dolby. But if the amp is off and just using the TV speakers the HD dolby channels dont work yet the normal stereo ones do ! The only way to fix it is to change (on sky) the hdmi output to "normal" rather than "dolby" , but then if I turn the amp on its not Dolby anymore ! My old sky box worked fine with the optical. Amp on = Dolby , Amp off = tv speakers.
So I assume its a setting on new Sky box thats causing this ?

If anyone has an Onkyo amp and a new Sky box , could you post up any settings relating to HDMI/AUDIO etc (whether they are optical/coaxial etc) as I find them a bit confusing on which does what , though I'm not too bad with these things.
 

Stevenage Neil

Distinguished Member
You need to assign the Sky input on your amp to optical input! (Needs to be changed in two places in the Onkyo set up.)
 

CharlySkunkWeed

Novice Member
But none of my amp settings have changed since it worked on the old sky box using optical cable ? I assume before the audio was opical and the video was hdmi. So why cant it stay like that ?

My confusion is the settings on the Onkyo amp , there seems to be a couple of areas that relate to this but cant decipher which ones to tinker with.
 

Stevenage Neil

Distinguished Member
So, referring to your post in another thread, frowned upon by the Mods in posting twice), you say:-
......The only way to fix it is to change (on sky) the hdmi output to "normal" rather than "dolby" , but then if I turn the amp on its not Dolby anymore ! .......

You've set HDMI to output stereo. Your amp is receiving the HDMI input - hence a stereo output.

Your previous set up only had optical going to the amp.

As said previously you need to assign optical to the Sky input on your amp.
 

CharlySkunkWeed

Novice Member
I assume it was already on this setting before I got new box though ? Can you put up the settings I need ( just what they say , I can find them and change accordingly)

I see - Digital Audio , have a choice of - coaxial 1, coaxial 2 , optical. I have selected optical.

or in Source Setup I see - Audio Selector , have a choice of HDMI , Optical , analog. I have tried Hdmi and optical both giving no joy.
 

Stevenage Neil

Distinguished Member
Right, sorted now...

Input Mode on receiver needed to be changed from Auto to Opt, and then coax - and Sky now coming through amp in Dolby digital loveliness, with normal sound going to tv when amp on standby.

Doesn't that mean you have to keep muting/unmuting the TV speakers or are you using the TV speakers as your LF and RF speakers?
 

CharlySkunkWeed

Novice Member
So, referring to your post in another thread, frowned upon by the. Mods in posting twice), you say:-


You've set HDMI to output stereo. Your amp is receiving the HDMI input - hence a stereo output.

Your previous set up only had optical going to the amp.

As said previously you need to assign optical to the Sky input on your amp.
Sorry about the double posts , I will stick to my own thread. I just thought I would explain my specific setup over there
 

Stevenage Neil

Distinguished Member
I can't remember now, but first you have to set up the Sky source input on the AVR to select optical, having first set the Sky box HDMI to normal and Optical to Dolby.
 

CharlySkunkWeed

Novice Member
Just got it !

In Source Setup , Audio Selector , pick "optical"
In Sky menu set Optical to Dolby , and HDMI to Normal.

This is probably what I was being told , but I was getting caught up in too many settings !

Thanks.
 

logiciel

Moderator
Welcome to the forum.

Much the simplest way to handle this is to use the Onkyo on all the time.
 
Last edited:

Stevenage Neil

Distinguished Member
Welcome to the forum.

Much the simplest way to handle this is to use the Onkyo on all the time.

Saves having to mute the TV speakers whenever you want surround sound........
 

CharlySkunkWeed

Novice Member
My wife rarely uses the amp , and when the inlaws house-sit when we're on hols it keeps things simple.

No need to mute tv speakers etc , there are settings on my Onkyo to solve that problem , if needed I can find out what they are:thumbsup:
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom