Dolby Atmos has suddenly stopped working (but only on some of my apps)

Thomas Bland

Standard Member
Hi everyone

I’ve ran into a really puzzling situation with Dolby Atmos, and was hoping someone else might have had a similar problem that knows what to do. Up until yesterday, it was working perfectly fine using my TV (Panasonic HZ2000), soundbar (Samsung HW-950T) and streaming stick (Fire Stick 4K). Now today its stopped working...but not completely. Using my Fire Stick 4K, I can no longer get Dolby Atmos on either Netflix or Apple TV+. Instead I’ve now only got the option of 5.1.

What’s strange though, is that I can still get Dolby Atmos on the Disney Plus app, using the exact same set up (same streaming stick, TV and soundbar). I can also still get Atmos on Netflix, but only when using the TV’s own app.

Having tested my 4K blu ray player (UBP-X700). Dolby Atmos works fine when playing 4K blu rays, but there's no option for Atmos when using the Netflix app on it.

I’ve tried everything I can think of to resolve the issue...

I’ve plugged the stick directly into the TV, in case it was an error with soundbar.
I’ve tried changing various settings on the Fire Stick and TV.
I’ve done a factory reset on my TV, soundbar and Fire stick.
I've tried using a Roku Premium stick. That also used to play Atmos on Netflix, but doesn't now.

There are so many variables, I cant seem to narrow down the issue.

Any advise?
 

The latest video from AVForums

Panasonic HZ2000 OLED TV Review: The best OLED for movie viewing in 2020
Top Bottom