Docking Station problem

-Spike-

Well-known Member
Hi all,

Hoping someone might be able to help....

I have a Marantz RC5000i with docking station, problem is I had the green light on the front of the station flash while it was charging and after switching off and on again it doesn't charge at all :(

Unit is a year old. I've tried everything suggested by the manual and at Remote Central - battery seating, dodgy contacts, resetting the r/c etc, but still the green light stays off and no charging starts

Looks like the docking station is broken, or possibly the Nimh battery, anyone have any other ideas about what else I could try?

Regards
 

-Spike-

Well-known Member
Update

Now got the charging light to come on by altering the battery seating but it's now only charging to 50% :(

Looks like I'll have to clean the contacts with an eraser to see if that helps....
 

-Spike-

Well-known Member
Well tried cleaning the contacts on the NIMh battery, now charging up to 75% but no more.

Guess I'll have to live with this as long as it doesn't display low battery level very quickly.

May try a new battery.

Anyone else had this?
Am I speaking to myself here or just boring you all? ;)
 

buns

Banned
hi!

I actually notice this at times....... i just take the thing off and keep charging until the battery is full. It always lasts a fair while anyhow so i havent worried too much.

ad
 

-Spike-

Well-known Member
buns,

Cheers for the reply, appreciate it
Regards
 

buns

Banned
I will have a bit of a play with mine and see, having never thought about it, i havent yet fiddled! The best that i can say from previous charges is that it is almost as if the unit moves from its charge spot on the dock.....so i fiddle it about a bit and away it goes charging, come back a bit later, the same trick works again. If i work anything out better than that i'll tell you!

ad
 

-Spike-

Well-known Member
Thanks buns,

I'll give what you suggest a go, hope it works.
I don't know if it hasn't been charging fully for very long, but I do remember seeing the charge bar full before

I guess it's no great problem, like you say, if it lasts for a while -then no worries
Maybe all the negative posts regarding this on Remote Central gave me paranoia :rolleyes:

All the best
 

chips

Active Member
I have the same problem with mine, I just keep taking it off the charger and putting it back on. Also I re-seat the battery every month or so. It's a pretty poor design.
 

-Spike-

Well-known Member
Cheers chips,

Glad I'm not the only one with the problem on here ;)

Regards
 

Gliese 581c

Distinguished Member
Thats normal to take the remote off the charger and put it back on.

Its more a pain than a problem. These batteries charge in timed bursts. Thats why it charges for a period of time then you have to lift the remote and place it back down to repeat the process.

Its meant to prolong the life of the battery by charging using this method.
 

The latest video from AVForums

LG C1 OLED TV Best Picture Settings for SDR, HDR and Dolby Vision
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom