DJI Naza wont run

pete-c

Standard Member
My H quad will not run after being stored for a few months. It flew OK when I last used it.

I have connected up to the computer and everything seems OK. Have also done a motor test and that is OK

Any help appreciated
 

noiseboy72

Distinguished Member
Won't start?
Do a stick calibration, as sometimes these can prevent the Naza from starting if you cannot get the sticks right to the corners.

Check and calibrate IMU and compass. What light sequences do you get, as this will tell you what the issue is.
 

pete-c

Standard Member
Hi thanks for the reply

Everything seems OK Am getting 2 green and 2 reds on startup then as it locks on the sats it goes to 2 green.
 

noiseboy72

Distinguished Member
Check switch positions on the radio control, check r/c is binding correctly, receiver is still connected etc. consider re-loading firmware...

It's quite an old FC now, so it's possible it has failed, but check the obvious stuff first.
 

nheather

Distinguished Member
It's quite an old FC now, so it's possible it has failed, but check the obvious stuff first.

I’d be surprised if a flight controller just dies when sat on a shelf, batteries yes, but electronics would be unusual.

I suspect that it is not arming - probably needs recalibrating.

Cheers,

Nigel
 

noiseboy72

Distinguished Member
Yep, my first thought, but you cannot rule out something like some damp getting into it, or corrosion on the connections, that sort of thing.
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom