Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Display problem

Discussion in 'General TV Discussions Forum' started by Andythebubble, Oct 23, 2005.

  1. Andythebubble

    Andythebubble
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I have tried searching but i cannot find any direct help to my problem.

    My 4 year 25" philips tv only displays the fuzz signal and no picture, or no sound. All plugged in and everything, and is no signal problem because before this occured, it was on the blink and would switch off from the picture, and display this fuzz while playing the sound.

    Apparently they have a powering problem.

    Could any shed some light on the problem, and is it DIY fixable.

    Thanks
     
  2. nig28

    nig28
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Hi
    Most TV faults cannot be repaired by a DIYer.
    At only 4 years old it might be worth repairing if you are prepaired to go to the trouble.
    Does the TV work ok if you play a DVD or video via the scart lead?
    What is the model number?

    Nigel
     
  3. Andythebubble

    Andythebubble
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Thanks for the reply. I will find out this weekend, and post the new info.
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice