Dim laptop screen

Elmer

Member
I recently had a fault on a 8 year old Fujitsu AH532 laptop screen where when it is turned on for the first time each day it has purple lines for the first few minutes. Plugging the laptop into an external monitor showed that it was the screen itself which was the issue so I purchased a compatible replacement.

The new screen was noticeably dim when compared to the original screen. I checked that it was on full brightness and updated the drivers, still the same. I put the original screen back in and that was fine at normal brightness.

I contacted the supplier to see if they had any ideas, they checked and said that the supplied screen had the same brightness levels in it's spec as the original. I returned it to them they tested it and found no fault. I purchased a different make of compatible screen from a different supplier but found this too is exactly the same, working but noticeably quite dim.

Any ideas?

Thanks
 

EndlessWaves

Distinguished Member
Laptops are frequently provided with multiple models of screen, so it's possible that it matched some of the screens the AH532 came with.

Did you buy the screen based on the laptop model, or the existing screen panel?
 

Elmer

Member
Hi I did try and buy the screen based on the existing panel (CP565226-01 Rev 02A). I contacted Fujitsu who said spares ended for the laptop in 2017 and pointed me to Procurri Europe to see if they could help.

Procurri confirmed what Fujitsu had said that the original panels weren't available but said their recommended panel for the laptop was now a cp666057-01. They quoted £156 delivered but couldn't tell me if the panel was matte like the original screen or gloss. £156 seemed to be a bit excessive for a laptop which cost £355 new and I wanted to have matte the same as the original so I looked online for cp666057-01 screens and bought one for £78 stating that it was matte.

As that screen proved to be too dim, the second screen I did just find by searching for Fujitsu AH532 matte screens and checking that it had the correct brackets and connector.
 

The latest video from AVForums

Paramount + UK launch: Halo, Star Trek and Beavis, and all the latest 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom