Desktop not powering on

roman700

Active Member
Hello

My Dell 8700 desktop (about 8 or 9 years old) won't power up. When I press the main power on button, nothing happens at all. It has been playing up for a few weeks in that sometimes it works when I press it, and sometimes it doesn't, needing 3 or 4 goes typically.

There is an orange light on inside the case, and the green test button on the outside of the power supply works OK.

I have replaced the button battery, no difference.

Could it be that a new power supply is necessary? If I go that way (don't know much about them), do they come with instructions to point me to where I should plug each mini-plug? They have a lot of wires! One to to the SDD, one to the....etc etc. Maybe it would be more straightforward than I imagine.

The only other symptom I have noticed is that twice in the last few days I've been working and the monitor turned blue! Not a typical blue screen of death with a Windows message, just all blue. The desktop has a graphics card (and maybe eating into the power needs excessively, tho' I think it's a low end one).

I've just taken out the dedicated graphics card, still not powering up.

Any ideas? Wonder if a new power supply is worth a gamble. I wouldn't know where to start, but know I don't want to spend all that much (ideally). It's an old computer.

Thanks.
 

JollyJamma

Active Member
Hard to tell.

It could be a PSU issue, it could be a dead motherboard.

Typically, motherboards die after about 6 to 8 years of use so it might be that.

Hard to tell without plugging in a known working PSU and trying to power it on.

Buy the PSU, try it. If it works, great. If it doesn't work, return it.
 

roman700

Active Member
Thanks. I've also heard it could be a dodgy button/connection from button to motherboard.

That's good to know that you can return such items. I was worried that once opened/tried, returning becomes difficult.
 
check with the vendor but a lot will take returns.

if your OK with this - here is a possible method for testing the button by bridging the pins when the switch is removed from the motherboard.

there is a simliar thread of information about how to test it for that model of dell here

 

roman700

Active Member
Thanks very much. I tried that and it powers on... I think that means that the button or connections from the button are faulty, but I'm not sure. I am going to see if I can remove the old button/connectors (looks complicated) and if feel, I might try a new button/connectors, about £22ish.
 

roman700

Active Member
Oh, I'll investigate further! Not really fussed about looks. This would be cheaper, and simpler, than the "proper" button. Easy to fit I guess?
 

roman700

Active Member
Just looking at this again. The "POWER SW" end would fit in the computer (I know where) and the other end is the button/switch I would use to power on...is that right?

The cable would just feed out the case (that might have to be left slightly open?).

Is that how it works?
 

roman700

Active Member
Thanks! This cheap little solution has done the trick. Thanks so much!

Cable looks a bit untidy but really not a problem and quite charming! Ha!

Very grateful for the help and all the replies.
 

The latest video from AVForums

Prey + Bullet Train reviews, Heat 4K + Event Horizon 4K and all the latest movies and TV news
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom