Dension Ice>Link Plus Firmware

benoutram

Standard Member
Hello

I have a Dension Ice>Link Plus with firmware v4-4.14 installed.

I'm experiencing a bug where the iPod audio level defaults to 4V everytime the head unit is turned on.

The latest firmware I can find on their support site is v2-2.17

Does anyone have any later firmware for v4? Their technical support and organisation of their website seem really poor. :mad:

My head unit is a Renault Tunerlist.

Thanks.
 

martmiller

Active Member
hi, I would send them an email.

I had an issue with a Nashville DAB35 and they ended up sending me a far later firmware than was available on their website.

I would offer to send it to you, but it was a blaupunkt specific config one.

mart
 

benoutram

Standard Member
Thanks for your reply. I sent them an email over a week ago and haven't received a response yet. Hopefully not long now :)
 

mattjazz

Standard Member
Have you heard anything yet?I have the same problem with my renault.I have also emailed incar support so we'll wait and see.:thumbsup:
 

benoutram

Standard Member
Is it exactly the same problem? Incar support got back to me straight away with new firmware. I have yet to hear from Dension!
 

mattjazz

Standard Member
Yes ,its exactly the same,very annoying.So the firmware from incar made no difference?I have heard elsewhere that the Dension help site is no more!
 
C

CoolGav

Guest
I have recently changed cars and am trying to get my Ice>link working on the new Renault (with Update List HU). Where can I download the firmware that will support it, since my Ice>Link is from 2005, with 2.10. I know how to change from SONY to Renault, but Dension/In-car websites are poor at describing and giving links for the firmware update.
 

benoutram

Standard Member
I have recently changed cars and am trying to get my Ice>link working on the new Renault (with Update List HU). Where can I download the firmware that will support it, since my Ice>Link is from 2005, with 2.10. I know how to change from SONY to Renault, but Dension/In-car websites are poor at describing and giving links for the firmware update.

This is the link to the 2.17 firmware that I found while looking for 4.15 firmware for myself. Install it at your own risk!

http://install.dension.com/ICE-LINK_PLUS_FW_217.zip
 

mattjazz

Standard Member
I've got my ice link working ok now,but there is quite a bit of engine interference at low noise levels.Also my radio never tunes as well now ,there is a lot of static on the stations!
 

The latest video from AVForums

Podcast: Cleer Audio speaker + HiFi Rose Streamer Reviews & Movie/TV Show talk
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom