1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Denon "Mech error..."

Discussion in 'Home Cinema Buying & Building' started by ringworm2, Oct 8, 2005.

  1. ringworm2

    ringworm2
    Banned

    Joined:
    Apr 28, 2005
    Messages:
    1
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    1
    Ratings:
    +0
    Hi all,

    I recently attempted making my Denon ADV-500sd region free by applying the software found in another thread in this forum. Well, I burned the cd, inserted it and the denon seemed to accept. However, when I turned it on I got a "mech Error" on the screen and it won't even eject. Is there a way for me to re-set the machine so I can get it working again.

    I tried unplugging it for a couple of days, but I get the same message.

    Any help would be greatly appreciated.

    Thanks
     
  2. thomo99

    thomo99
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    bet you wished you never messed with it now, sorry to say that but a message to most, if you dont know what your doing , dont do it.
     
  3. Conn

    Conn
    Active Member

    Joined:
    Jan 2, 2005
    Messages:
    2,056
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    66
    Ratings:
    +170
    Hmmm....I did exactly the same thing.... :(

    Sent it back to the retailer I bought it from - unrepairable, they gave me a new one. Must admit I was not completely open and honest as to what had caused the error ;) I was fortunate enough to have removed the disc before it died, avoiding any tricky explanations.

    Good luck.
     

Share This Page

Loading...