Dismiss Notice
Attention AVForums app / Tapatalk users
Sadly GDPR means that, from 25th, we can no longer offer access to AVForums via the branded app or Tapatalk.
Click here for more information.

Denon Link Problem

Discussion in 'AV Receivers & Amplifiers' started by toonarmynufc, Aug 25, 2005.

Tags:
  1. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    I Have A Denon A1sr Amp And A 3910 Dvd Player When I Connect The Dvd Player And The Amp Via Denon Link The Lock Indacator On Mt Amp Flashes On And Off .the Sound Come And Gos Any Ideas Chaps
     
  2. S H A D O

    S H A D O
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    10,435
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    United Kingdom
    Ratings:
    +1,813
    I assume you've checked the cables in the socket properly?
     
  3. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    Yes Ive Checked The Cable 2 See If Its In Right
     
  4. S H A D O

    S H A D O
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    10,435
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    United Kingdom
    Ratings:
    +1,813
    Does it do this for all signals or is it something specific e.g DVD Audio?
     
  5. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    all signals
     
  6. S H A D O

    S H A D O
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    10,435
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    United Kingdom
    Ratings:
    +1,813
    The Denon Link socket on the A1SR is marked as Denon Link S.E (or Denon Link 3 if the Amp is the A1SRA) isn't it?
     
  7. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    my amp is a a1sr not a a1sra
     
  8. S H A D O

    S H A D O
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    10,435
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    United Kingdom
    Ratings:
    +1,813
    Does the Denon Link have a little S.E sticker next to it??
     
  9. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    nope it just says denon link on the back of the amp.on the dvd player it has 3rd i think the dvd player mite be dodgy
     
  10. S H A D O

    S H A D O
    Well-known Member

    Joined:
    Mar 16, 2001
    Messages:
    10,435
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    136
    Location:
    United Kingdom
    Ratings:
    +1,813
    That's your problem. Denon Link is NOT compatible with Denon Link S.E or Denon Link 3. You need to have your Amps Denon Link upgraded. Your DVD player is fine.

    Denon are offering an upgrade for the A1SR to A1SRA spec which includes Denon Link 3, HDCD and Dolby PLIIx. Best bet is to contact them and ask when this will be available for the UK (Denon Germany have been doing it for a while now). You'll have to pay for the upgrade though, if I remember correctly it's around 250 Euros (170 quid).
     
  11. toonarmynufc

    toonarmynufc
    Guest

    Products Owned:
    0
    Products Wanted:
    0
    Ratings:
    +0
    cheers i will have 2 do that then
     

Share This Page

Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice