Denon/Heos/Spotify

elliottserjeant

Novice Member
Hi all.

Been searching for days about this small but niggly issue…

I have a Denon Home 250 which I use with Spotify connect on my iPhone. I have the Heos app installed but never use it as a control.

First up, I hate queues or Spotify radio or any any algorithms that pick my music. I just want to listen to an album and then pick another when it’s done. I don’t want to finish an album and some random songs that I never picked start up.. Can this be so hard?

Sometime in the last few months the automatic queue feature in Spotify has switched on only when in use with the Denon. If I go into the Spotify queue I can’t delete any of the songs it’s lined up. The settings menu on Spotify where I can control the queue options goes grey (ie not changeable) when connected to the Denon. So maybe there are settings to be changed in the Heos app? But I can’t find any.

This doesn’t happen on my car stereo or my headphones. It happens exactly the same on my wife’s phone so it’s not some setting unique to me.

I get that this seems like a Spotify issue but it’s only when I’m connected to the Denon..

Any help would be much appreciated…
 

Helix Hifi

Well-known Member
Not familiar with Heos. As I understand it’s Denon, Marantz answer to Bluesound. The latter is very popular.

As I understand Heos should be pretty straight forward to use. There should be something called audio settings.

In the Spotify app. Go to settings menu. There’s ⚙️ symbol in the right corner.

Find the options which says play similar songs to the artist/album you listen to the most. Turn this option off. Done. No more similar music like the album you just listen to.

I don’t understand why you find it so difficult to just switch to another album, after you are done listening to the previous albums.

You can make your own playlist, if you want to. It seems this an issue also. There you can delete songs etc.

Spotify algorithm picks similar music you listen to the most. If you listen to classical music, then more Bach well pop up in the Spotify app.

I don’t see why this is an issue.

Contact Spotify support if you can’t find out why the Denon is acting strange. Or Denon.

Also google Spotify queue. Sometime after Spotify updates the software, the app might change.

Hope this helps.
 

elliottserjeant

Novice Member
Thanks for your reply..

Trust me I’ve been through every settings menu countless times. It’s just the “playback” menu where the “auto play” switch is unavailable when connected to the Denon via connect.

I guess I’m ‘old school’ or something, as I want to listen to albums like I would on a record player. Aka the album plays and then it stops and there is silence. That prompts me to pick another. I don’t want playlists or selections that aren’t my own.
 

Helix Hifi

Well-known Member
Have you turned off the options “familiar song”?
 

Kapkirk

Active Member
Thanks for your reply..

Trust me I’ve been through every settings menu countless times. It’s just the “playback” menu where the “auto play” switch is unavailable when connected to the Denon via connect.

I guess I’m ‘old school’ or something, as I want to listen to albums like I would on a record player. Aka the album plays and then it stops and there is silence. That prompts me to pick another. I don’t want playlists or selections that aren’t my own.
Please read the following from the spotify community moderator.

Hello everyone,
We've noticed multiple threads on the topic of Autoplay concerning connected devices and have done our best to merge them all here. Our goal is to try and keep the communication centralized and clear up any confusion on the matter.

First up - we can confirm that as of recently, the Autoplay setting is turned on automatically and by default for any connected device. This means that whenever you play music from Spotify on a device different than natively on your phone or pc/mac (installable apps, not our Web Player) Autoplay will be enabled and tracks will be added to continue playback. This will happen regardless of the current active Autoplay setting. This setting affects only the playback directly on your phone or pc/mac (apps) and does not work universally.

As of now there's no way to choose if you want to have Autoplay enabled on a connected device. We assume most of you posting here would like an option for this. As such, it will be really helpful if you go and cast your vote for this idea. This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better. We will follow up on this matter with the right team and try and find out more about this ourselves and will keep you posted.

We are also noticing reports about devices that have Autoplay enabled by default, that, at least from what we understand, should not exhibit this behavior. This might explain some of the contradicting info you've stumbled upon. We'll follow up on this as well.

Please stay tuned for updates. We understand that this change might cause frustration depending on your music listening habits. It is our humble ask that we keep the conversation civil and friendly. We'll do our best to pass the feedback on, but it can take some time for us to be able to follow up. We promise we will do so as soon as we have anything to share.

Thank you!
- The Community Moderator team
Jump to reply
MattSuda

MattSuda
Rock Star 24

‎2021-12-01 12:37
As mentioned by @JalapenoMunich

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

More info here:

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176
Jump to reply
 

Helix Hifi

Well-known Member
Familiar songs or auto play is what I mean. Turn it off.

Speaking of Denon/Heos. I don’t know, since it’s another platform then Spotify.

What Spotify really should do; is to enable audio normalization. Without using airplay. The latter is unstable, to put it mildly.

Well... It’s never going to happen.
 

elliottserjeant

Novice Member
Please read the following from the spotify community moderator.

Hello everyone,
We've noticed multiple threads on the topic of Autoplay concerning connected devices and have done our best to merge them all here. Our goal is to try and keep the communication centralized and clear up any confusion on the matter.

First up - we can confirm that as of recently, the Autoplay setting is turned on automatically and by default for any connected device. This means that whenever you play music from Spotify on a device different than natively on your phone or pc/mac (installable apps, not our Web Player) Autoplay will be enabled and tracks will be added to continue playback. This will happen regardless of the current active Autoplay setting. This setting affects only the playback directly on your phone or pc/mac (apps) and does not work universally.

As of now there's no way to choose if you want to have Autoplay enabled on a connected device. We assume most of you posting here would like an option for this. As such, it will be really helpful if you go and cast your vote for this idea. This will allow us to better understand how big exactly the demand for something like this is so we can prioritize better. We will follow up on this matter with the right team and try and find out more about this ourselves and will keep you posted.

We are also noticing reports about devices that have Autoplay enabled by default, that, at least from what we understand, should not exhibit this behavior. This might explain some of the contradicting info you've stumbled upon. We'll follow up on this as well.

Please stay tuned for updates. We understand that this change might cause frustration depending on your music listening habits. It is our humble ask that we keep the conversation civil and friendly. We'll do our best to pass the feedback on, but it can take some time for us to be able to follow up. We promise we will do so as soon as we have anything to share.

Thank you!
- The Community Moderator team
Jump to reply
MattSuda

MattSuda
Rock Star 24

‎2021-12-01 12:37
As mentioned by @JalapenoMunich

An update has been posted. An option to disable Autoplay on connected devices will soon be coming to the desktop app first and then the mobile app at a later time. The setting works globally so if you turn Autoplay off in the desktop app for connected devices, it will also be off in the mobile app when playing to connected devices.

More info here:

https://community.spotify.com/t5/Live-Ideas/AutoPlay-Option-to-toggle-Autoplay-on-off-across-all-devices/idc-p/5303176
Jump to reply
Hey thanks for this, exactly what I was looking for. No idea why Spotify would make it work like this.
 

Kapkirk

Active Member
Hey thanks for this, exactly what I was looking for. No idea why Spotify would make it work like this.
Yeah it's a real pain in the a$$ hopefully with enough people complaining spotify will sort it out in a future update.
 

The latest video from AVForums

Maverick UK Premiere IMAX Review + Top Gun, Tom Cruise, Tony Scott and 4K + Movie/TV News
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom