Denon Has A Problem With 2910/2807

sunshinebob

Standard Member
Denon have got a wide spread problem.


I purchased a 2910 dvd and a 2807 amp but I can not get the pass through to work. When the 2910 DVD is connected directly to the projector ( hdmi ) is all perfect. The picture and sound blows me away.... But when I set it up the (hdmi) pass through into the amp it fails to work at all... I need the pass through of course to watch the telly / video / playstation etc... I have updated the firmware courtesy of denon support (thanks) but to no avail.. its not the settings or leads.. I have tried 2 x 2910 dvd's and 3 x 2807 amps and all have the same problem. Its Denon.. They have a problem with the HDMI hand shake thing. The projector ( a brand new IN76) , amp and the DVD / source all have to talk to each other and they dont/cant.

I have spent some time googling this and it appears that its happening all over the globe. Some in the US , UK , Canada and down-under too. I would say to anyone looking at a 2910/2807 package to be very careful at the moment and dont buy untill this is ironed out.

The real question is "Has anyone had this problem and if so how did they resolve it?"....

Any ideas would be greatly recieved....

sunshinebob.
 

Eddy Boy

Active Member
Have you tired another display, like a fujitsu or some other?

If not how do you know the amp is not exposing a problem with your PJ?
 

sunshinebob

Standard Member
Eddy,

Thanks for the reply

I have not tried another tv.. I have tried another IN76 projector as its the first thing I got swapped... The PJ does of course work perfectly well when connected to the 2910 DVD player directly in "non-pass-through" setup.

Also the HDMI light flashes on/off when in the non-working pass through mode and when I press the status buttton on the amp it does not see the PJ. It appears there is a problem with the hand over of the video signal as it passes through the amp. The amp ticks as its looking for a video source.

Please keep your thoughts coming.. Between you guys and denon there must be a solution.

thanks again

sunshinebob
 

aud1oKat

Active Member
I have a Denon 1920 and a Denon 2807 and a Pioneer plasma and they work fine passing the signal thru the receiver; both audio and picture without a glitch at all.
I guess it's your screen.
 

Jase

Distinguished Member
Maybe the PJ doesn't like HDMI Repeaters (which is what the 2807 would act as). Does an S-Video signal converted to HDMI and de-interlaced by the 2807 work ok?

Presume you've assigned the HDMI Input to the relevant source Input etc?
 

sunshinebob

Standard Member
thanks for your replies...

It appears that the three components do not talk the same HDCP.. When the DVD is connected to the PJ is 100%.. As soon as the amp is connected by HDMI to the PJ as a pass throught things go wrong. Its the passed through signal that is not being recieved at the PJ.

I today ran an composite video connection to the PJ from the amp. I can now watch all other sources via this lead. The DVD is still connected by HMDI and so whilst this works I now am unable to get HD quality except from the DVD player.

Infocus say their product will play whatever its gets sent as long as its ok and Denon say try a different PJ or monitor.

I googled about and this HMDI protocol HDCP is causing denon all sorts of problems.. My dealer has three other similar issues...

sunshinebob.

PS... Whould s-video or something else give me a better picture than composite?
 

Jase

Distinguished Member
sunshinebob said:
PS... Whould s-video or something else give me a better picture than composite?

Composite is the worst quality signal you can feed something. It goes from worst to best in this order usually:-

Analog signals:- Composite, S-Video, Component and RGB.

Digital signals:- DVI (RGB only), HDMI (can carry either RGB or Component signals).

If you have Component Outs on your gear use those, if not, then S-Video can look very good. All are way better than Composite.
 

sunshinebob

Standard Member
Jase...

Thanks for your prompt reply.. I thought the TV picture looked pants.

Like you I am in spain (malaga area) and finding the right cables locally is not always the most simple thing.

So this afternoon I am off to look for a 10m component video cable ( or failing that 10m s-video ) and to try to get it going at last. It wont be 100% right but it will be more than half right.

I will let you know. Any further help or advise anyone has will be greatly recieved.

sunshinebob
 

Jase

Distinguished Member
sunshinebob said:
I googled about and this HMDI protocol HDCP is causing denon all sorts of problems.. My dealer has three other similar issues...

There are issues with HDMI but the main culprits are Satellite boxes/Cable boxes that won't work HDMI repeaters. This isn't down to the Denon as it conforms to spec. It's down to the Sat Box/Cable Box providers to issue firmware updates to correct this.

Other issues have been noticed on the Denon 3806 with regards to the analog to HDMI conversion. A lot of displays/pj's etc can't accept interlaced signals (480i/576i) via HDMI. An example would be someone taking a signal from a Sky+ box (576i via S-video) and feeding it to a Denon 3806 for conversion to HDMI. The 3806 will convert that to HDMI but keep it at the same resolution i.e 576i as it has no onboard scaling/de-interlacing. The result is no image on some displays.

Again, technically that's not really down to the Denon as the display can't accept that signal it's outputting.

The 2807 has the added benefit of de-interlacing so won't suffer from this.
 

Jase

Distinguished Member
sunshinebob said:
Like you I am in spain (malaga area) and finding the right cables locally is not always the most simple thing.

So this afternoon I am off to look for a 10m component video cable ( or failing that 10m s-video ) and to try to get it going at last. It wont be 100% right but it will be more than half right.

Try these guys:- :)

http://www.tucineencasa.com/quienesomos/delegaciones/index.html

Oficinas: Urb. Las Terrazas de Bel-Air
Bloque 6 - 10 . Estepona 29680
Tlf. +34 630 223 712 Fax. +34 952 88 72 55
email:[email protected]
Contacto: J. Luis Salazar
 

aud1oKat

Active Member
Hey Jase; good to see you around.
I will be asking you soon some advice about my Denon setup. I am almost finishing it. :thumbsup:
 

IRobot

Well-known Member
HDMI pass through is a pain in the arse with the 2807. I had the same problem with trying to get a signal from a Denon 1920 DVD to a HD72i via the 2807. The HD72i scans all its inputs looking for a signal. I stopped it from doing this by switching off all inputs apart from HDMI in the options menu. This seems to have sorted out my problem.
 

sunshinebob

Standard Member
Irobot..

RE:- De selecting all other PJ imput souces.

I tried that and the PJ froze.. Apparantly there is also a fault on the software with the new IN range. If you de-select all other source imputs it goes a bit mad. Infocus have released a firmware update on the 17th of this month to combat this problem. I downloaded it from the internet and am looking for the M1 to USB connection cable that I need to upload the software onto the PJ.

I love new technonlgy... I just wish it would bleeding work out the box!!

Keep those ideas coming....

sunshinebob
 

sunshinebob

Standard Member
So the dealer ( sevenoaks in manchester ) who has been great all along today sent me a 10m component cable.. And bingo it works..The system does not work as a hdmi pass-through but it does with RGB.

I have sound and video from the DVD only in HDMI and every thing else ( tv , video , playstation ) in component. Its half working but not as it should.. If I had a HD sky box I would not be chuffed watching HD telly via a non-HD connection. This set up has cost 5 grand and it don't work.

The dealer is talking to Denon to get to the bottom of this and hopes to have some news sooner rather than later. This is still a problem. HDMI is still not 100% right currently. Be warned...

sunshinebob.
 

magrillz

Active Member
sunshinebob said:
So the dealer ( sevenoaks in manchester ) who has been great all along today sent me a 10m component cable.. And bingo it works..The system does not work as a hdmi pass-through but it does with RGB.

I have sound and video from the DVD only in HDMI and every thing else ( tv , video , playstation ) in component. Its half working but not as it should.. If I had a HD sky box I would not be chuffed watching HD telly via a non-HD connection. This set up has cost 5 grand and it don't work.

The dealer is talking to Denon to get to the bottom of this and hopes to have some news sooner rather than later. This is still a problem. HDMI is still not 100% right currently. Be warned...

sunshinebob.


Hi mate,

I had a similar problem with my DVD-2910. it was working fine connected directly to the Plasma via HDMI but when I sent the signal through my AVR4306 it was a no go. Turned out the 2910 needed a firmware update as it was still on hdmi v1.0 and the amp was running hdmi v1.1. After the firmawre update all was ok.

I got the link from this forum. Can't remember the exact link as at work and a bit busy. If you can't find it let me know and i'll check tomorrow night when Iam free :smashin:
 

ellisr63

Standard Member
I also have a problem with the HDMI on the Denon 2807 and my panasonic AE900. From what i understand they are not compatible.
 
A

and64

Guest
magrillz said:
Hi mate,

I had a similar problem with my DVD-2910. it was working fine connected directly to the Plasma via HDMI but when I sent the signal through my AVR4306 it was a no go. Turned out the 2910 needed a firmware update as it was still on hdmi v1.0 and the amp was running hdmi v1.1. After the firmawre update all was ok.

I got the link from this forum. Can't remember the exact link as at work and a bit busy. If you can't find it let me know and i'll check tomorrow night when Iam free :smashin:

Hello,
I also need a firmware update for my Denon DVD 2910. Would you please be so kind and post the link or send me a private message?:lease:
 

magrillz

Active Member
For anyone else who needs it i got the update from

http://www.denon2910.freehomepage.com/

Not sure if it will fix this particular problem you guys are having but it did the trick for my compatability issue. Good luck guys, will be interested to see if it fixes it :smashin:
 
C

cafnand

Guest
HI,
I have just bought a 2807 and when connected to an older 2910 and samsung 40"LCDthe HDMI pass through does not work. this is a similar problem to those above. I've been reading all the threads and it looks like a firmware upgradeis in order but am stuggling to find a link for the firmware that works and am not sure which version i should go for.
If anyone can point me in the right direction i would greatly appreciate it.

Many thanks,
Andrew
 

The latest video from AVForums

Star Wars Andor, Woman King, more Star Trek 4K, Rings of Power & the latest TV, movies & 4K releases
Subscribe to our YouTube channel

Full fat HDMI teeshirts

Support AVForums with Patreon

Top Bottom