• New Patreon Tier and Early Access Content available. If you would like to support AVForums, we now have a new Patreon Tier which gives you access to selected news, reviews and articles before they are available to the public. Read more.

Denon DPB1611UD Audio Problem

Snaggletooth

Established Member
Hi

Had this in the Blu Ray forum but very little response, so moved here in hope of some comments.

Has anyone experienced or is aware of any problems associated with the Denon DPB1611UD playing CD's?

I ask because at the weekend I put on a CD (AC/DC's awesome Highway to Hell) and was unable to get any sound. I have it connected via the the Analogue Audio Outputs (2.0ch) to a Marantz 1501 receiver. The Denon is only about 2 months old, bought new and up to this have had no problems. It played perfectly the last time I used it (possibly last Wednesday) and I haven't changed any of the cables/settings etc. I do get sound when I switch to digital though. I haven't yet tested the cable through my TV (hadn't got a chance as it means removing TV from wall) incase its the cable's fault, but I'd doubt it.

My big concern is that it is a connection problem associated with Denon products. I got a second hand Denon DBP2010 prior to getting the 1611UD and had to return it due to problems with the power supply.

Any thoughts/suggestions greatfully appreciated.

Thanks.
 

The latest video from AVForums

Spielberg, Shyamalan, Aronofsky, Chazelle, Eddie Murphy and Mel Gibson - all the latest movies
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom