1. Join Now

    AVForums.com uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Denon: Blown speaker?

Discussion in 'Home Cinema Speakers' started by OldSkoO1, Dec 11, 2004.

  1. OldSkoO1

    OldSkoO1
    Member

    Joined:
    Nov 27, 2004
    Messages:
    565
    Products Owned:
    0
    Products Wanted:
    0
    Trophy Points:
    28
    Ratings:
    +30
    Hi all

    I recently got a Denon 500SD home cinema system. Its great in every way apart from what happened the last night. I swapped my temp scart/phonos for my ntl sound feed for some quality phono interconnects from tv phono out to the denon amp.

    It was going fine, i set up my sony tv to output what sounded like the correct volume. Then i watched a dvd. After the dvd i switched back to the Video 1 function which is my ntl feed but the TV was still on AV-1 for my DVD. This caused a very loud, high pitched sound. The kind of sound thats so amplified it becomes distorted. Firstly any ideas what happened? All connections were firmly in place. I figured out that the headphone output volume setting on the TV caused this because it was too high (as it controls phono out too). I dropped it a bit and was unable to replicate the problem.

    Now im worried ive damaged the speaker in some way. Im sure it was only the centre speaker. I ran a few tests by watching some parts of dvds and the tv and it doesnt sound like anything is drastically wrong but im worried that ive blown out some frequencies. Is this possible and if so how can i test for this; or would it just be noticable?


    Thanks in advance!

    Mr.Paranoid! :rolleyes:
     

Share This Page

Loading...