Denon avr-x2700h Sound dropouts

Evolad

Novice Member
Hi guys,

So recently purchased the x2700h and had nothing but issues with it lately. I'm using eacr but noticed like 2 second sound drops every now and then, more noticeable on my xbox series x.

My Tvs a Samsung Q90T and have tried a couple of different leads with the same problem. I've altered every setting possible. Also done a factory reset on TV and receiver.

I decided to plug all hdmi's in the amp and turn off earc. I started getting the drop outs but with the picture as well?

Gone back to using earc now but it's really annoying me. If I could get a refund I would but I've had it over a month now. Seen a few posts about similar issues but I can't figure it out. Can't even speak to denon as their hiding behind covid still.

Any help or advice would be great.

Thanks Dave
 

blofse

Member
Hi guys,

So recently purchased the x2700h and had nothing but issues with it lately. I'm using eacr but noticed like 2 second sound drops every now and then, more noticeable on my xbox series x.

My Tvs a Samsung Q90T and have tried a couple of different leads with the same problem. I've altered every setting possible. Also done a factory reset on TV and receiver.

I decided to plug all hdmi's in the amp and turn off earc. I started getting the drop outs but with the picture as well?

Gone back to using earc now but it's really annoying me. If I could get a refund I would but I've had it over a month now. Seen a few posts about similar issues but I can't figure it out. Can't even speak to denon as their hiding behind covid still.

Any help or advice would be great.

Thanks Dave
Did you buy in the UK? If so, you have consumer rights for this scenario. For the first six months, it's up to the retailer to prove there isn't a fault, so they are very unlikely to disagree with you that there isn't a fault. From what you describe, it does sound faulty. Are these drop outs when your content switching or are they randomly during playback? If the latter that's probably faulty. If the former, that may well be the denon doing its thing.
The retailer will most likely offer a repair, they may offer you a refund. I would talk to your retailer to at least register the fault with them. See these links for help:
Return faulty goods
 

Evolad

Novice Member
Did you buy in the UK? If so, you have consumer rights for this scenario. For the first six months, it's up to the retailer to prove there isn't a fault, so they are very unlikely to disagree with you that there isn't a fault. From what you describe, it does sound faulty. Are these drop outs when your content switching or are they randomly during playback? If the latter that's probably faulty. If the former, that may well be the denon doing its thing.
The retailer will most likely offer a repair, they may offer you a refund. I would talk to your retailer to at least register the fault with them. See these links for help:
Return faulty goods
Hi, cheers for the reply. Its during playback but it seems more the xbox causing the issues. Could atmos be the issue. I'm monitoring it now as I can only recall the problem while using the xbox.

Yeah I'm from the UK. I'll get in touch with the retailer and log it. Cheers
 

The latest video from AVForums

AVForums Movies Podcast: Streaming Theatrical Releases And The Future Of Cinema
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom