Denon AVR-X2600H Bluetooth input issues

hcslekvak

Member
I recently aquired a Denon AVR-X2600H receiver and are experiencing issues with the Bluetooth input mode. After initially pairing, my phone (Android, Pixel 5) is connected and plays back audio from the phone no problem. After disconnecting, e.g. from the phone, the device is listed under previously connected devices on the phone. However, after swithing to another input and back to "Bluetooth", the receiver attempts to automatically reconnect, but nothing happens other than that the device disappears from the device list on the phone.

In other words; it seems like the device is unpaired from the phone when the receiver attempts to re-initiate a connection, and must be re-paired (each time!). This is not the case for some BT speakers I have; these are able to reconnect the phone as soon as they are turned on, so I was hoping the AVR was able to do the same.

Anyone experiencing similar issues? (Unfortunately, I do not have another phone to test at hand at the moment, but I guess thats the next step...)

Supposedly, according to the manual, it should, for instance, also be possible to reconnect from the phone without having to interface with the receiver itself: Reconnecting to this unit from a Bluetooth device AVR-X2600H

The screen automatically switches to the “Bluetooth” playback screen if a Bluetooth device is connected while the power of this unit is on.
 

The latest video from AVForums

Samsung S95B Update, B&W Panorama 3 & Q Acoustics Reviews, HDR PQ EOTF/Gamma Calibration Discussion
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom