Denon AVR electrical hissing

N1ck

Active Member
I have just picked up a pre owned Denon 2313. Using Kef 2001.3 speakers impression are great although I have only set up a simple 5.0 system to try it out. Sub to be added in a few days. The difference between this and my Yamaha sound bar is like chalk and cheese.

My main concern so far, however, is a disconcerting electrical sounding ‘hiss’ coming from it. It’s louder when in standby and quieter, although still present, when turned on.
It is noticeable when next to the amp but pretty much inaudible when 2-3 meters away. Whether it has any other cables attached makes no difference.

Is this normal? It’s been many years since I last had a Denon receiver but I can’t remember hearing any hissing.

I have enclosed pictures of where the noise seems to be coming from.
 

Attachments

  • F39A7DE8-1BE5-4D0D-81B3-42EC10113B0C.jpeg
    F39A7DE8-1BE5-4D0D-81B3-42EC10113B0C.jpeg
    508.6 KB · Views: 26
  • 34469EE2-E82A-47B0-8461-CB5DFF708C54.jpeg
    34469EE2-E82A-47B0-8461-CB5DFF708C54.jpeg
    619.5 KB · Views: 25
  • 53DBDE2F-84D5-4FC1-A4ED-895C49AE5C87.jpeg
    53DBDE2F-84D5-4FC1-A4ED-895C49AE5C87.jpeg
    200.4 KB · Views: 27

dobrykamil

Well-known Member
That hiss sound is a common issue with some SMPS type power supplies after being used for number of years. It can be a bit annoying, but I wouldn’t worry about it too much.
 

N1ck

Active Member
Ok thanks. It’s not causing any issues and it’ll be in a cabinet so even less of an issue. As long as it’s safe and not using loads of electricity unnecessarily.
 

The latest video from AVForums

Samsung S95B QD OLED Review - A Quantum Leap for OLED!
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom