Quantcast

Question DENON AVR-2308 No picture and intermittent sound

NewProjectorMan

Standard Member
Hello folks,

I have issues with my AV set up (Denon Amp which is about 10 years old).

There is no picture and the sound only works intermittently. The speaker symbols are flashing intermittently also.

The projector is working fine (no problem when connected TV box/DVD player directly to the projector), seem to be working fine.

We have tested the HDMI cables so the amp or how it is set up seems to be the issue. The place is used as a serviced accommodation/holiday home so wondering if a guest has tweaked with the setting to cause this?

Any help greatly appreciated as has got my friend and myself stumped.

Cheers.
 

dante01

Distinguished Member
I'd suspect the cables. There's not a setting that would cause such issues. Cables act differently with different hardware so just because they work with other devices isn't to say that they'd work with the AV receiver.

How long is the cable from the AV receiver to the PJ? It is more often than not the length of the cable to a PJ that causes problems. You should ideally be using HIGH SPEED HDMI cables no more than 8m in length and ideally less than 6m. For cable runs longer than this then consider using HDMI over HDBaseT or even over fibre optic if wanting to convey higher bandwidth UHD video signals.
 

NewProjectorMan

Standard Member
Thanks for your reply but pretty certain it isn't the cables. These cables have worked for a long time with no problems and nothing has changed plus they have worked one 2 different other devices. Its only 2-3 metres from AV receiver to PJ.
 

akasmiler

Active Member
I'm having similar issues with sound from mine atm. It clicks out into a sort of mono sound, but muting and then un muting is temporary fix for it
 
Top Bottom