Denon AVR-1604 - a couple of teething problems with secondhand unit

plurpley

Novice Member
Hi all! I recently picked up a cheap secondhand Denon AVR-1604 receiver. I've never owned an AV receiver before, but I had a brief opportunity to demo the unit before I bought it and it seemed to be working okay. I've now set it up at home and I'm having a couple of teething problems.
  1. The receiver came with the original AM antenna loop, but I realised when I got home that the FM antenna was missing. I aim to purchase a replacement FM antenna, and in the meantime I was hoping to listen to AM radio. I assumed this would be pretty straightforward, but when I set the input to tuner I get an "Ext. In" message and the receiver won't let me change the band (either from the unit or the remote). Is this expected behaviour? Is it because I don't have the FM antenna connected? For some reason, do I need to have the FM antenna connected before the receiver will let me change the band to AM?
  2. I was hoping to play music from my phone via AUX IN, but unfortunately I can't get that working either. I connected my phone to the front audio inputs using a 3.5mm to 2 x RCA cable, and then set the input to AUX IN. Unfortunately, no sound. I tried increasing the volume on the receiver and on the phone, still no sound. Am I doing something wrong? Do I need to connect to the rear AV inputs instead? Do I need to connect the phone to another device before connecting to the receiver?
Regards, P.
 

The latest video from AVForums

Samsung Micro LED, Mini LED, NEO QLED TVs and More: AVForums Podcast Interview
Subscribe to our YouTube channel
Support AVForums with Patreon

Top Bottom